Common - last updated 2/1/19




* Project Flow

\ N Create 1 wy.
Design Verify via Test Verify via Program Verify via
HDL RTL Bench simulation DE10 DE10
myDesign.vhdl| myDesign_tb.vhdl myDesign_de10.vhdl|

Common 2 © tj



* Create a new Project

* Select File -> New Project Wizard

» See project setup slides if necessary
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Common

e Create a new HDL file

e Select File -> New -> VHDL File

D G r MyFirstCounter > 7 é‘

Project Navigator «% Hierarchy > gg =

Entity:Instance
A% MAX 10: T0MOSDAF484CEG Intel’' Q s Prim
Design Softwal

# MyFirstCounter "2
Find Out How |

aul (O A A A <<Filters> |

|||+:rux‘*\

Type ID Message
O 253020 pefault device 10MOSDAF484C8G is automati

© 253020 pefault device 10MOBDAF484C8G is automati

New Quartus Prime Project

™ Design Files
AHDL File
Block Diagram/Schematic File
EDIF File
Osys System File
State Machine File
SystemVerilog HDL File
Tcl Script File
Verilog HDLE]

VHDL File

Files

Hexadecimal (Intel-Format) File
Memaory Initialization File

¥ Verification/Debugging Files
In-System Sources and Probes File

Logic Analyzer Interface File




e Create a new HDL file

 Note the default file name

* We want this to be our top level entity so must change
the name

File Edit Wiew Project Assignments Processing Tools

Window Help
O s L MyFirstCounter v L& Y ES SLOE
Project Mavigator, +% Hierarchy T QiRa x &
Entity:Instance @ m ﬁ’ = = [l ﬂ‘ ‘D lm - %g; ;
&% MAX 10 TOMOSDAF454C8G *
® MyFirstCounter &1

<

> £
=
& [ Al Q .tt: i Ny <<Filter==
o

M Eind.
Common

8 Find Next
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* Create a new HDL file
» Select File -> Save As
e Set the file name to the our desired value
* Change the file extension to vhdl (for VHDL files)
* Make sure “Add file to current project” is checked

Save As
UK <« Projects » MyFirstDE10Project

Organize « MNew folder

-~

»~ lab o] Marme
¢& OneDrive % db

= This PC
[ Desktop
=] Documents
‘. Downloads
J’! Music
&=/ Pictures

B videos

o TIT0T16000F (C:)

v £

w

O

X
Search MyFirstDE10Project )
= @
Date modified Type

7142017 5:32 PM File folder

Save as type:  WHDL Files (*.wvhd *.whdl)

» Hide Folders

© tj



Common

* Create a new HDL file
* Note the name change

File Edit WView Project Assignments

Processing  Tools  Window Help

A% MAX 100 10MOEDAF484CEG
P MyFirstCounter "B

(h Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_Q1_EE3921/Projects/MyFirstDE10Praject/MyFirstCounter - MyFirstCounter

P ES L0

281 =
265 —.

O = C MyFirstCounter |
'S A )
Project Navigaton % Hierarchy v |Q e = 2 4 MyFirstCounter.vhdl
= =
Entity:Instance B ey =
1

< >« >
x|
allan (B | A A A | <<Filters> M Eind.. | &8 Find Next
o
= || Type ID Message
@ 253020 pefault device 10MO8DAF484c8G is automatically selected for the device family max 10
© 253020 pefault device 10MOSDAF484C8G is automatically selected for the device family mAx 10
b
g
E System (2) Processing
00:00:00
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e Create a new HDL file
* Enter your VHDL code

Eile Edit View Project

O r=  a)io)

Assignments

MyFirstCounter

Processing  Tools

Window Help

’ A A
# E%
M - X<

G Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_03_CE1911/Projects/Lab_Projects/MyFirstDE10Project/MyFirstCounter - MyFirstCounter
] ] Y ) y Y

P ES LR O

Project Navigator =] Files v algd x| & myrirstCountervhdl (&} Compilation Report - MyFirstCounter G myFirsic 4| ¥ |IP Catalog o x
- = ’
Files @ &7 E ol ﬂ% 0w ﬂ B o= |.s X =
) 38 [architecture behavioral of irstcounter 1s .
E% MyFirstCounter_del10.vhdl 9 g . . myf v J Installed IP
B |k10Hz vhdl :g - Internal Signals “ Project Directory
E® MyFirstCounter.vhdl :g signal cnt_sig: unsigned(7 downto 0); No Selection £
E® MyFirstCounter_tb.vhdl 44 @ begin ¥ Library
45 @ -
46 L -- Update section Basic Functions
47 -
48 = Ero;ess(c'lk) DsP
gg ‘ egin Interface Protocols
51 o if (rstb ="0") then L Memory Interfaces and Controllers
Tasks Compilation =008 x| 52 - cnt_sig <= (others => '0°);-- reset
53 @ elsif (rising_edge(clk)) then Processors and Peripherals
ek ~l|52 @ if (dir = '0°) then T
a8 55 | ] cnt_sig == (cnt_sig + 1); -- count up University Pragram
rormeile Decion 56 B else
v P Compile Desig 57 cnt_sig <= (cnt_sig - 1); -- count down @ scarch for Partner P
v P Analysis & Synthes 38 cJem:i if;
ANysIs & - = 59 end if;
B Edit Settings g;’ end process;
. - v 62 = _ v
< ] > < + Add.
=
g | an| @D |& A (A | <<Filters> 88 Eind. | B Find Next
i}
= || Type ID Message
i
b
i
E System Processing (18)
100%  00:01:00
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e Create a new HDL file
* Enter your VHDL code

---Project Header---
-— MyFirstCounter

-- Created: 2/23/18

-- By: johnsontimoj

-- For: CE1911

-—--Project overview---
-- This project creates a binary up/down
-- counter

--- Project Details ---

-- Inputs: rsth, clock, dir
—-— OUTpUtsS: Cnt

-- dir determines up({0) or down(l)
-- Library inclusion

Tibrary ieee;

use ieee.std_logic_1164.all;

use ieee,.numeric_std.all;

entity MyFirstCounter is

port( i_rsth: in std_logic;
i_clk: in std_logic;
i_dir: in std_logic;
o_cnt: out std_Tlogic_vector {7 downto 0)

H
end entity;

architecture behavioral of myfirstcounter is

-- Internal Signals

signal cnt_sig: unsigned(7 downto 0);
begin

- Update Section

_;ogess i_clk, i_rsth

egin

if {i_rsth ="0") then

cnt_sig «= (others == '0');-- reset
elsif (rising_edge(i_clk)) then

if (i_dir = '0') then

cnt_sig <= (cnt_sig + 1); -- count up
else
cnt_sig <= (cnt_sig - 1); -- count down
end if;
end 1f;:

end process;

-- Qutput Section

o_cnt «= std_logic_vector{cnt_sig);

end architecture;

10
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e Create VHDL file

* Create a component template for your design (DUT)

e Select File 2 Create/Update = Create VHDL Component
Declaration Files from Current File

Copyright (C) 2017 Intel Corporation. All rights reserved.

-- Your use of Intel Corporation's design tools, logic functions

-- and other software and tools, and its AMPP partner logic

-- functions, and any output files from any of the foregoing

-- (including device programming or simulation files), and any

-- associated documentation or information are expressly subject
-- to the terms and conditions of the Intel Program License

-- Subscription Agreement, the Intel Quartus Prime License Agreement,
-- the Intel FPGA IP License Agreement, or other applicable license
-- agreement, including, without limitation, that your use is for

-- the sole purpose of programming logic devices manufactured by
-- Intel and sold by Intel or its authorized distributors. Please

-- refer to the applicable agreement for further details.

-- Generated by Quartus Prime Version 17.1 (Build Build 590 10/25/2017)
-- Created on Fri Feb 23 09:52:29 2018

11

COMPONENT MyFirstCounter

PORT
(
i_rstb : INSTD_LOGIC;
i_clk : INSTD_LOGIC;
i_dir : INSTD_LOGIC;
o_cnt : OUTSTD_LOGIC_VECTOR(7 DOWNTO
0)
);
END COMPONENT;
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e Create VHDL file

 Verify your code is synthesizable

e Set the VHDL file as the Top-Level Entity

* In project Navigator — Files, Right click the VHDL file and select:
Set as Top-Level Entity

e Select Processing -> Start -> Start Analysis & Elaboration

Analyzes and elaborates all files in the hierarchy of the current top-level entity

File Edit View Project Assignments Processing Tools Window Help
D = r MyFir 5 essing Ctrl+Shift+C
jProject Navigator E Files v Q[ P Start Compilation Ctrl+L
‘ Files Analyze Current File
| BT myFirstCountervhdl Start > hﬁ.
Update Memory Initialization File B
[ & Compilation Report Cti+R [*
-
& Dynamic Synthesis Report ﬁ
Power Analyzer Tool H
1 m SSN Analyzer Tool E‘h
Receive Compilation Status Nofifications a;
Tasks Compilation T|=EE @ Flow Suppressed Messages Total loj -
! Task Total rey
[
~ P Compile Design Total pit
Total vir
v P Analysis & Synthesis B
Total m
W Edit Settings
1 Embedc
[ .
< > < > ||« e
x L] =2
5| an O A A A <Filter> BOrnd. .,
it
B = | Type ip Message
o quartus Prime analysis & elaboration was successful. 0 err
g <
:
§ 2] system(1)  Processing (9) -5}

P @

(b Quartus Prime Lite Edition - C/Tirm/GDrive/MSOE/18_03_CE1911/Projects/Lab_Projects/MyFirstDE10Project/MyFirstCounter - MyFirstCounter

SLOE O

- MyFirstCounter D

I -

Start Hierarchy Elaboration

Start Analysis & Elaboration

Start Analysis & Synthesis

Start Partition Merge

Start Fitter

Start Assembler

Start TimeQuest Timing Analyzer

Start EDA Netlist Writer

t Design Assistant
Start Power Analyzer

Start SSN Analyzer

Start Rapid Recompile

t Signal Probe Compilation
Start IfO Assignment Analysis

Start Check & Save All Netlist Changes

Start Equation Writer (Post-synthesis)
Start Equation Writer (Post-fitting)
Start Test Bench Template Writer

Start EDA Synthesis

|IP Catalog

Ctrl+K

Ctrl+shift+T

Ctrl+shift+P

Ctrl+Shift+l

irectory

Functions

ce Protocols

ry Interfaces and Controllers

isors and Peripherals

sity Program
- Partner IP

100%

00:00:21
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* Create VHDL file
* Check all Warnings and Errors

= 12021 Found 2 design units, including 1 entities, in source file myfirstcounter.vhdl
nghllght errors 12127 elaborating entity "MmyFirstcounter” for the top Tevel hierarchy
Quartus Prime Analysis & Elaboration was successful. 0 errors, 1 warning

and warning R

i
= | System (2}  Processing (8)
100% 00:00:19
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Eile Edit WView Project Assignments Processing Tools Window Help
D ~ r MyFirstCounter = 7 é‘ ‘5 o > K Q‘ @ #o » -‘ 9
Project Navigator +% Hierarchy rlofge =| ¢ MyFirstCounter.vhdl & Compilation Rep
Successful G
= |-.—_
% MAX 10: 10MOBDAF484CEG é e
= ~
MyFirstCounter 72 4 |Flow Status - Tue Jul 04 18:00:29 2017
%’ Quartus Prime Version 16.1.0 Build 196 10/24/2016 5J Lite Edition
. Revision Name MyFirstCounter
Top-level Entity Name MyFirstCounter
Family MAX 10
Device 10MOSDAF484C8G
Timing Models — you will get a large number of warnings
Total logic elements N/A until Partition Merge if you read in the qsf file —_ 1 for every
Total registers N/A until Partition Merge d .
Total pins N/A until Partition Merge unuse pl n
Total virtual pins M/A until Partition Merge
Total memory bits N/A until Partition Merge
i Y Ermhaddad tultinlicr 0_hit ol s KA nntil Dartitinn baroo 7
x L)
allan |8 (& 4 <<Filters> B Eind.. | 8 Find Next
n
= | Type IO Message ~
' 18236 Number of processors has not been specified which may cause overloading on shared machines. set the global assignment N
@ 20030 Parallel compilation is enabled and will use 2 of the 2 processors detected
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e Create VHDL file

* ALWAYS check your RTL to make sure it makes sense
 Select Tools = Netlist Viewers > RTL Viewer

i_clk [ >

idir[ >

-]
-
™,

|

1'h0 CiN - Add1

A[e..nf?f:\\ OUT[5.0]

cnt_sig[7.0

1]

nt_sig~[7..0]

=CLE 0

9'h1fd Bl2.0] Sl

1'h0 CiN AddO

-'-‘-.[?..I:E?f:\\, OUT[7.0]

- SCLR

]—I—D 0_cnt[7..0]

CLRM

S S

8'h1 B[7.0] W

i_rstb[ >

Common
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* Project Flow
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Common

* Project Verification
* Create a Test Bench

* Open a new vhdl| design file with the name
MyFirstCounter_tb

* Create a test bench entity and instantiate your design at
the device under test (DUT)

* Create test inputs using the non-synthesizable wait
instructions

17
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* Project Verification
* Create a Test Bench

-— MyFirstCounter_th. vhdl

-- created: 2/23/18
-- by: johnsontimoj
-- rev:

-- testbench for 8 bit counter
-— of MyFirstCounter.vhdl

-— brute force implementation

Tibrary ieee;
use ieee.std_logic_1164.all;

entity MyFirstCounter_th s
-- no entry - testhench

end entity;
architecture testbench of MyFirstCounter_th is
signal CLK: std_Tlogic;
signal RSTB: std_logic;
signal DIR: std_logic;
signal CNT: std_logic_vector(7 downto 0);

constant PER: Time := 20 ns;

COMPOMNENT MyFirstCounter

begin

-- Device under test (DUT)

DUT: MyFirstCounter

port map(

i_rsth => RSTE,
i_clk == CLK,
i_dir => DIR,
o_cnt == CNT
);

-— Clock process
clock: process
begin
CLKE == "0';
wait for PER/Z;
infinite: loop
CLK <= not CLK; wait for PER/Z:
end loop;
end process;

-- note - no sensitivity 1ist allowed

-— RUnN process
brute: process
begin

inputs

-- note - no sensitivity 1ist allowed

-- Initialize
RSTE <= "0";
DIR <= "07;

'0'; wait for
1" wait for

PORT -
( -- verify count up and roll over
i rsth IN STD LOGIC: DIR <= '0"; wait for 258%PER;
1Tk IN STD LOGIC: -— verify count down and roll over
-i:d-ir- N S_D:LOG:CE DIR <= .J..; 'I.'l'a.-it 'Fclr' EE‘EQPER;
o_cnt OUT STD_LOGIC_VECTOR{? DOWNTO 0)
J: end process brute;
END COMPOMENT, .
___________________________________ 8 end architecture;

Comm
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* Project Verification

* Elaborate the design

« With the original vhdl design set as the top level entity (not the
xxxx_tb.vhdl design)

e Select Processing = Start = Start Analysis and Elaboration

* This causes Quartus to check the Test Bench code along
with the original vhdl design

Common 19 © tj
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* Project Verification

e Setup the test bench
e Select Assighnments = Settings = EDA Tool Settings 2

Category:

Simulati

select File nam

Device/Board

General
Files
Libraries

IP Settings

<

IP Catalog Search Locations

Design Templates

<

Operating Settings and Conditions
Voltage

Temperature

<

Compilation Process Settings
Incremental Compilation

EDA Tool Settings

<

Design Entry/Synthesis
simulation
Board-Level

<

Compiler Settings
VHDL Input
Verilog HDL Input
Default Parameters
TimeQuest Timing Analyzer
Assembler
Design Assistant
signalTap Il Logic Analyzer
Logic Analyzer Interface
PowerPlay Power Analyzer Settings
SSN Analyzer

Specify options for generating output fiks for use with other EDA tools

Tool name: | ModelSim-Altera

[ Run gate-level simulation automatically aft

EDA Netlist Writer settings

Eormat for output netlist: | VHDL 100us
Output directory: |simulation/modelsim \
[ Map illegal HOL characters [ Exable glitch filtering

Options for Power Estimation

[ Generate Value Change Dump (VCD) file script  Seript Setfing:

More EDA Netlist Writer Settings.
NativeLink settings
O None
® Compile test bench: | synchronous_4bit_counter_tb Test Benches.
[ Use script to set up simulation

O script to compile test bench:

More NativeLink Settings. Reset

W Buy Software oK Cancel Apply Help

Common

- Test Benches
select the end simulation time

: enter the test bench file

... and select the test bench file

21

—" Edit Test Bench Settings

Edit test bench settings for the selected tgst bench.

Test bench name: |MyFirstCounter_tb l

Top level module in test bench: |MyFir5t’Zounter_tb

[ use test bench to perform VHDL timjng simulation

esign inst:

Simulation period

Test bench and simulation files

File name: | Add
File Name Library Remove
MyFirstCounter...
Up
Down
Properties...
oK Cancel Help
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* Project Flow
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* Project Implementation
* Prepare for DE10

* Create a new VHDL File
 MyFirstCounter_del0.vhdl

Use the DE10 pin names from the gsf file
e or you can use the pin planner

Instantiate your Design

Instantiate a clock divider
* slow down the operation so a human can see it

Common 24
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* Project Implementation
* Prepare for DE10

-— MyFirstCounter_del0. vhdl

-- created: 2,/23/18
-- by: johnsontimoj
-- rev: 0

-- DE10 file for & bit counter
-- of MyFirstCounter.vhdl

-- using gsf pin names
-— SM[O? --% reset

-- sW[1l] --> Dir

-- CLOCK_50 --> clock
-- LEDR --> Cnt

Tibrary ieeeg;
use ieee.std_logic_1164.all;

entity MyFirstCounter_delld 1is

PORT(
SW: in std_logic_vector (1l downto 0);
CLOCK_50: in std_logic;
LEDR: out std_logic_vector (7 downto 0)

)!
end entity;

architecture testhench of MyFirstCounter_del0 is
signal clocklOHz: std_logic;

COMPONENT MyFirstCounter

PORT
i_rsth IN STD_LOGIC;
i_clk IN STD_LOGIC;
i_dir IN STD_LOGIC;
o_cnt : QUT STD_LOGIC_VECTOR(7 DOWNTO 0)
H
END COMPONENT;
COMPONENT c1k10Hz
PORT
i_c1k_50MHz IN STD_LOGIC;
i_rsth : IN STD_LOGIC;
o_cTk_10Hz OUT STD_LOGIC

3
END COMPONENT;

DESIGN: MyFirstCounter

port map(
i_rsth =>
i_clk =>
i_dir =>
o_cnt ==

clk_divider: clklOHz

port map(
i_clk_50MHz
o_cTk_10Hz

i_rsth =>

end architecture;

sw(0),
clockl0OHz,
sw(l),
LEDR

=> CLOCK_50,
== clocklOHz,
sw0)

Common
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* Project Implementation
* Prepare for DE10

* Compile your design
* Check the Compilation Summary

.g =<Filters=

Flow Status

CQuartus Prime Version
Revision Name
Top-level Entity Name
Family

Device

Timing Models

Total logic elements
Total registers

Total pins

Total virtual pins
Total memary bits

Total PLLs
UFM blocks
ADC blocks

Embedded Multiplier 9-bit elements

Successful - Pri Feb 23 20:28:40 2018
17.1.0 Build 590 10/25/2017 5J Lite Edition
MyFirstDE10Project

MyFirstCounter_de10

MAX 10

TOMS50DAF484CT7G

Final

28 /49,760 (<1 %)

11|/ 360 (3 %)

26
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* Project Implementation
* Prepare for DE10

 Check the RTL

clk10Hz:clk_divider

MyFirstCounter:DESIGN

i_clk 50MH lk_10H i lk
CLDCI{_EGD i C _:-. z o_clk_ z |._c- )
SW["I..D]D 0 i rsth 1 i_dir I8 o cnt[7.0] D LEDR[7..0]
0 i_rstb
27
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Common 28 © tj



* Project Implementation
* Configure the DE10

e Select Tools -> Programmer
e point to the compiled output file
* start

Common 29 © tj
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* Project Implementation
* Configure the DE10

* Validate the design on the DE10 board

Common 31 © tj



