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* Quartus Prime — Project Setup

* Before creating your first Quartus project:

* Install the Quartus software — see “Quartus Software Setup”

* Projects are created for a top level design
* Create a project directory to keep all of your projects organized
* Eg. .../HDL/Quartus_Projects

* Your project folder should be placed somewhere in your
personal folder path — Not in the Quartus installation
directory

Common 2 © tj



* Quartus Prime — Project Setup

* Quartus uses directories to store projects in

* Create a separate directory for each project

* Eg. .../HDL/Quartus_Projects/MyFirstDE10Project

No spaces in the directory path

It’s best to not use any special characters in the project folder name
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* Quartus Prime — Project Setup

e Start the Quartus software
e Under File — select New Project Wizard ...

G Quartus Prime Lite Edition
File Edit WView Project Assignments Processing Tools Window Help

[ Mew.. Ctrl+N -

~ Open.. Ctrl+O

Close cuiers COLLABORATE. D
& Intel QI‘“" f'm ™
'k

E: 'D‘pEFI PrDjE'Ct_.. Ctrl+ Design Softwal
Save Project Find Qut How

Close Project
Save Ctrl+5

Save As...

A saveall Ctrl+Shift+S

File Properties...
Common 4 © tj



Common

* Quartus Prime — Project Setup
* Select Next

(% MNew Praject Wizard

Introduction

The New Project Wizard helps you create a new project and preliminary project settings, including the following:

Project name and directory

Mame of the top-level design entity
Project files and libraries

Target device family and device
EDA tool settings

* + 5 0

You can change the settings for an existing project and specify additional project-wide settings with the Settings command (Assignments
menu). You can use the various pages of the Settings dialog box to add functionality to the project.

[ pon't show me this introduction again

< Back Einish Cancel Help
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* Quartus Prime — Project Setup
e Select your project directory
*/Name your project
* Your project name and top level entity name should be

b New Project Wizard

Directory, Name, Top-Level Entity

What is the working directory for this project?

c:f LA !Projects/MyFirstDE10Project

What is the name of this project?

MyFirstCounter

What is the name of the top-level design entity for this project? This name is case s

design file.

MyFirstCounter

Use Existing Project Settings...

e Click Next
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* Quartus Prime — Project Setup
* Select Empty project

e Click Next

Common

(% New Project Wizard

Project Type
Select the type of project to create.
® Empty project
Create new project by specifying project files and libraries, target device family and device, and EDA tool settings.

O Pproject template

Create a project from an existing design template. You can choose from design templates installed with the Quartus Prime software, or

download design templates from the Design Store.

< Back Einish Cancel Help
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* Quartus Prime — Project Setup
* We will not add any files right now

([ ] CI iC k N eXt (# New Project Wizard x
Add Files

Select the design files you want to include in the project. Click Add All to add all design files in the project directory to the project.

Note: you can always add design files to the project later.

File name: | | Add

| X| [ Adday

File Name Type Library Design Entry/Synthesis Tool HDL Version

Remove
Up

Down

Properties

Specify the path names of any non-default libraries. | User Libraries...

< Back Einish Cancel Help
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* Quartus Prime — Project Setup
 Select Max 10 (DA/DF/DC/SA/SC) under Family
e Select Max 10 DA under Device
* Select 10M50DAF484C7G under Available devices

e Click Next

Ok New Project Wizard

Family, Device & Board Settings

Device Board

Device family

Eamily™SAX 10 (DA/DF/DC/SA

Device: (| MAX 10 DA

Target device

Auto device sel

® Specific device selected in "Available devices' list

Available devices:

lected by the Fitter

Select the family and device you want to target for compilation.

You can install additional device support with the Install Devices command on the Tools menu.

Show in ‘Available devices' list

Package: Any
Fin count Any

Core speed grade: | Any

To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List wet

Name filter:

Show advanced devices

PaE=

Name Core Voltage LEs Total I/Os GP10s Memory Bits Embedded multiplier ¢ ~

< T0ME50DAF484CTG 1.2v 49760 360 360 1677312 288 v
£ >

< Back FEinish Cancel Help
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e Click Next

/

* Quartus Prime — Project Setup
* Under simulation — select ModelSim-Altera and VHDL

Note: ModelSim-Altera

not ModelSim

Common

il Mew Project Wizard

EDA Tool Settings

Specify the other EDA tools used with the Quartus Prime software to develop your project.

EDA tools:
Tool Type Tool Name Format(s) Run Tool Automatically
Design Entry/Synth...  <None> ¥ | <Mone> Run this tool automatically to synthesize the current design
Simulation ModelSim-Altera ¥ | VHDL ) Run gate-level simulation automatically after compilation
Board-L Timing <Nones> -
= Symbol <None> -
signal Integrity <None> hd
Boundary Scan <None>

< Back Einish Cancel Help
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* Quartus Prime — Project Setup
* You will get a summary window

e Click Finish

Ik Mew Project Wizard

Summary

when you click Finish, the project will be created with the following settings:

Project directory:
Project name:
Top-level design entity:
MNurnber of files added:
Murnber of user libraries added:
Device assignments:
Design ternplate:
Family name:
Device:
Board:
EDA tools:
Design entry/synthesis:
sirnulation:
Timing analysis:
Operating conditions:

Core voltage:

Junction temperature range:

C:/Tim/GDrive/MSOE/18_Q1_EE3921/Projects/MyFirstDE10Project
MyFirstCounter

MyFirstCounter

0

0

nfa
MAX 10 (DA/DF/DC/SA/SC)
10MS0DAF484CT G

nfa

<MNone= (<Monez)
ModelSim-Altera (Verilog HDL)
0

1.2V

0-85°C

< Back Mext = Cancel Help
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* Quartus Prime — Project Setup
* Your project will now appear in the Project Navigator

window

(¥ Quartus Prime Lite Edition - C:/ o060 Project/MyFirstCounter - MyFirstCounter

File Edit View Project Assignments Processing Tools Window Help

Or= r MyFirstCounter v L& PFES SLODN®

Project Mavigator, % Hierarchy > Qag x

S— COLLABORATE. D

N MAX F484C36G Intel’ Quakiius’ PFim
Design Softwans

#* MyFirstCounter &1 |
Find Out How

Quartus Prime

Version 16.1 Lite Edition

>

|||4=m><|f~

|Messa,ge5

Al |9 Al A A | <<Filters> M rind_ | |8 Find Next

m|

Search altera.com

= Buy Software

% Download

*

Type ID Message

© 253020 pefault device 10MOSDAF484C8G is automatically selected for the device family mMax 10
© 253020 pefault device 10MOBDAF484C8G is automatically selected for the device family max 10

System (2) Processing

00:00:00

12

Ot



* Quartus Prime — Project Setup
* We will be using the 2008 version of VHDL
e Assignments -> Settings -> Compiler Settings -> VHDL

Input

General
+ Select VHDL 2008
Libraries
¥ IP Settings
IP Catalog Search Locations
Design Templates

“ Operating Settings and Conditions
Voltage
Temperature

v

Compilation Process Settings
Incremental Compilation
¥ EDA Tool Settings
Design Entry/Synthesis
Simulation
Board-Level
¥ Compiler Settings
WHDL Input
Verilog HDL Input
Default Parameters
TimeQuest Timing Analyzer
Assembler
Design Assistant
Signal Tap Logic Analyzer
Logic Analyzer Interface
Power Analyzer Settings
55N Analyzer

VHDL Input

Options for directly compiling or simulating VHDL input files. (Click on the EDA Tool Settings category to enter

options for VHDL files generated by other EDA tools.)
VHDL version

O wHDL 1987

) vHDL 1993

® VHDL 2008

Library Mapping File

File name: |

[ show information messages describing LMF mapping during compilation

W Buy Software oK Cancel

Apply

Help
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* Quartus Prime — Project Setup
* If you plan to run the project on the DE10
and

e you want to use the assigned pin names (recommended)
* you need to import the DE10 _Lite.gsf file from the web page

* right click the link and save link as (DE10_Lite.qgsf, QSF file type) in
the project directory

* Assignments -> Import Assignments
* Point to your downloaded DE10_Lite.qsf file

@ Import Assignments x

Specify the source and categories of assignments to import.

File name: |C :,"...P DE10_Lite.gsf Categories...

Copy existing assignments into MyFirstCounter.gsf.bak beforeim| | Advanced..

OK Cancel Help
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* Quartus Prime — Project Setup

* Proper placement and routing requires that the design
meets a set of timing requirements

* A very basic set of timing requirements is available in the
file Basic_SDC.sdc on the web site

* You will use this as a starting point for each project you
create

Common 15 © tj



* Quartus Prime — Project Setup

* Select Tools -> TimeQuest Timing Analyzer

G_WE_EESYL 1S FIOJECTS! IVIY FITSTLE IUF IO eCTf IVIYTITSTLOURTEr - IVIYFITSTL OUNTEr

sing | Tools  Window  Heln

=

x

Common

Run Simulation Tool

Generate Simulator Setup Script for IP..

Launch Simulation Library Compiler

Launch Design Space Explorer |1
TimeCuest Timing Analyzer
Advisors

Chip Planner
Design Partition Planner

Metlist Viewers

SignalTap Il Logic Analyzer

) o O 4

nstraints

Reports Script Tools Window Help

B & * || Getting Started

Tasks

€

f: Open Project...

Netlist Setup

P Create Timing Netlist

P Read SDC File

P uUpdate Timing Netlist

P Reset Design
[

5. Liqanrran gaen g 4 1r S Tnar #r_f:

T —

ATear_gef” ra -

pan o
View pane into
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* Quartus Prime — Project Setup

e Select File -> New SDC File
* Copy and paste the contents of Basic_SDC.sdc into the file

View Metlist Constraints

Reports

Script Tools

Wwindc

Mew SDC File
Open... Ctrl+O

Close

Page Setup...

Print Preview

Print... Ctrl+P

SDC Files »

Common

ne x

b=

Getting Started

he TimeGiuest Timing A e

irming perfor

ting methodao

& Text Editor - C:/Tim/GDrive/MSOE/18_Q1_EE3921/Projects/MyFirstDE10Project/MyFirstCounter - MyFirstCounter - [M... O X
File Edit Wiew Project Processing Tools Window Help
— b1 —
@ 68 7 ull ﬂ ‘h 0w s —
W I m 48 # set Clock Groups ~

50

51

54 # Sset False Path

56

57

58

60 # set Multicycle Path

62

63

64

66 # set Maximum Delay

68

69

70

72 # Set Minimum Dela

74

75

76

78 # Set Input Transition

80

81

82

84 # Set Load

’ v

< >

Ln85 Cole4 Synopsys Design Constraints File 00:00:00
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* Quartus Prime — Project Setup
e Select File -> Save As

 Name the file the same as your project name
It should default to your output files directory

e Save and close the TimeQuest window

Save As

€ v

3 This PC

[ Desktop
=] Decuments
‘ Downloads

J'! Music

| Pictures

E Videos
o TIOT16000F (C:)

== JohnsonCloud (*

¥ Network

File name:

« MyFi

Organize = Mew folder

~

rstDET10Project » output_files o

#~

Mame

| MyFirstCounter.sdc

O

Search output_files

Date modified

8/31/2017 1:33 PM

Type

sDC

File

» Hide Folders

Save as type: | Synopsys Design Constraints Files (*.sdc)

[+] Add file to current
project
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* Quartus Prime — Project Setup

* Configure the tools for the DE10_Lite board
Assignments -> Device -> Device and Pin Options ->
Configuration -> Configuration Mode
and select
single uncompressed Image with Memory Initialization

Uk Device and Pin Options - LAB3 X

Category:

General Configuration

Configuration
Programming Files

Specify the device configuration scheme and the configuration device.

Unused Pins Configuration scheme: Internal Configuration %
Dual-Purpose Pins
Capacitive Loading
Board Trace Model Configuration device

1/0 Timing Single Compressed Image with Memory Initialization (512Kbits UFM)
Voltage Single Uncompressed Image (3584Kbits UFM)

Pin Placement Single Uncompressed Image with Memory Initialization (512Kbits UFM)

Configuration mode: |Single Uncompressed Image with Memory Initialization (512Kbits UFM) bt
Dual Compressed Images (512Kbits UFM)
Single Compressed Image (5888Kbits UFM)

Error Detection CRC
CvP Settings
Partial Reconfiguration [[] Force vccio to be compatible with configuration 1/O voltage

VID Operation mode
Configuration pin:

Generate compressed bitstreams




* Quartus Prime — Project Setup

* Your project is ready to use
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