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* Create a new Project

e Select File -> New Project Wizard

» See project setup slides if necessary
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* Create a new BDF file
* Select File -> New -> Block Diagram/Schematic File

Memory Interfaces and Controllers

(b Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_Q3_CE1911/Projects/Dero_Projects/MyFirstDE10Project/MyFirstDE10Project - MyFirstDE10Project —
File Edi * pw Help
% New X . ~
Ofs S EEL D FESSLOR 9
Project Nay Mew Quartus Prime Project ~ ort - MyFirstDE10Project @ |IP Catalog
Ty AHD ¥ * v i installed 1P
By, Flow Status Successful - Fri Feb ™ w : ;
e Block Diagram/Schematic File Project Directory
y Bult Global Set{ | Quartus Prime Version 17.1.0 Build 590 10/ No Selection
G My - = Time Revision Mame MyFirstDE10Project ¥ Library
B My Qsys System File mary Top-level Entity Name MyFirstLogic Basic Functions
B vy State Machine File Family MAX 10 DSP
ERE cli SYStEmVEr'ing HDL File boration Device TOMS0DAF484CT7G Interface Protocols
= Tel Script File s Timing Models Final
Tasks | - ; -
Verilog HDL File sed Messages | | Total logic elements N/A until Partition M Processors and Peripherals
Total registers N/A until Partition M eare
VHDL File . . - University Program
w Total pins M/A until Partition M e Search for Partner IP
v .
Memary Files Total virtual pins N/A until Partition M
Hexadecimal (Intel-Format) File Total memory bits N/A until Partition M
Memory Initialization File Embedded Multiplier 9-bit elements  N/A until Partition M ,
A . . + add.
< B ¥ Verification/Debugging Files >||< L -
x N
2 | A In-System Sources and Probes File 88 cind. | |88 Find Next
i} Logic Analyzer Interface File
=|DF signal Tap Logic Analvzer Fil hd -
d 1Enal 1ae Loeic Analvzer il ocess was successful. 0 errors, 1 warning
E System (3] Processing (20]
100%

00:00:02
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e Create a new BDF file
* Note the default file name

* We want this to be our top level entity so we must

change the name

(T Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_Q3_CE1911/Projects/Demo_Projects/MyFirstDE10Project/MyFirstDE10Project - MyFirstDE10Project

File Edit View Project Assignments Processing Tools Window Help

D) s r

Project Navigator E Files

P FES SLOE @

~ aln/& x| 4 compilation Report - MyFirstDE10Project € Block1bdf [}

B rQWACTE-O711 7NN (500 =] » 5

MyFirstDE10Project v L

>

|IP Catalog g =

Q x| =

MyFirstLogic_tb.vhdl
MyFirstLogic_de10.vhdl
MyFirstLogic.vhd
MyFirstCounter_tb.vhdl
MyFirstCounter_de10.vhdl
MyFirstCounter.vhdl
clk10Hz.vhdl

Compilation A

Task
~ P Compile Design
~ P Analysis & Synthesis

B Edit Settings

M Eind. | A Find Next

v it Installed 1P

¥ Project Directory

~ Library
Basic Functions
DsP
Interface Protocols
Memory Interfaces and Controllers
Processors and Peripherals
University Program

e Search for Partner IP

+ Add..

Ill-nmx|
2
[x]
B
b 4

Type ID Message
o Quartus Prime Netlist viewers Preprocess was successful. 0 errors, 1 warning

|Messa,ges
~

System (3) Processing (20)

284,93 100% 00:00:02
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* Create a new BDF file
» Select File -> Save As
e Set the file name to the our desired value
* Make sure “Add file to current project” is checked

project

Save As >
A « Lab_Projects » MyFirstDE10Project » v Search MyFirstDE10Project »
Organize = Mew folder == - o
)
8 Thic PC -~ Marne Date modified Type
W 3D Objects v db File folder
I Desktop ~ incremental_db File folder
| Documents » output_files File folder
~ simulation 2/23/2018 10:20 AM  File folder
4 Downloads . . T — -
ﬁ MyFirstLogic.bdf 2/21/2018 11:00 AM  BDF File
J’! Music
= Pictures
______ Videos
i TI10716D00F (C:)
== JohnsonCloud {f
v < >
Filegar@tmgic.bdf »
Save as type: | Block Diagram,/Schematic Files (*.bdf) ~
[ Adgl file to current
~ Hide Folders Save Cancel

7

© tj



* Create a new BDF file
* Note the name change

(W Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_03_CE1911/Projects/Demo_Projects/MyFirstDE10Project/MyFirstDE10Project - MyFirstDE10Project

— O X

File Edit WView Project Assignments Processing Tools Window Help Search altera.com |e-
O r= r MyFirstDE 10Project v L EE PEFES LR ®
Project Navigator @ Files ~laf@e x| @ Compilation Report - MyFirstDE10Project i MyFirstLogic.bdf B |IP Catalog pg x
Files AEIRAYWACTE-OTTIAINNTOO NN | » . x| =
E3 wyFirstLogic. bdf v i Installed 1P
MyFirstLogic_tb.vhdl v Project Directory
MyFirstLogic_de10.vhdl No Selection Available
MyFirstLogic.vhd ~ Library
bl MyFirstCounter_thb.vhdl Basic Functions
ﬂ% MyFirstCounter_de10.vhdl DSP
MyFirstCounter.vhdl “ Interface Protocols
Memory Interfaces and Controllers
Tasks Compilation - S8 =
Processors and Peripherals
A
Task University Program
~ P Compile Design e Search for Partner IP
v P Analysis & Synthesis
B Edit Settings
W
< — PR N + add..
x L]
g |l an| || A (A |A <<Filters> 8 rind. | | Find Next
il
= || Type D Message ~
o qQuartus Prime Metlist viewers Preprocess was successful. 0 errors, 1 warning
o v
o
EIR >
E Systemn (3)  Processing (20)
-64, 257 100% 00:00:02
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* Create a new BDF file
* Create your schematic

(W Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_03_CE1911/Projects/Derno_Projects/MyFirstDE10Project/MyFirstDE10Project - MyFirstDE10Project

File Edit View Project Assignments Processing Tools Window Help
O r= r MyFirstDE10Project v| LG PEFESSLOE®
Project Mavigator E Files v Qe = Q Compilation Report - MyFirstDE10Project ﬂ MyFirstLogic.bdf@
Files AE I RQWATE-O71TINNS YOO N YR » »

|IP Catalog 18 =
Q X| =

R

E3 wyrirstlogic bdf

v gk installed IP

MyFirstLogic_tb.vhdl ¥ Project Directory
MyFirstLogic_de10.vhdl No Selection Available
% MyFirstLogic.vhd ¥ Library
MyFirstCounter_tb.vhdl Basic Functions
MyFirstCounter_de10.vhdl DSP
MyFirstCounter.vhdl v Interface Protocols
Memory Interfaces and Controllers
Tasks Compilation =8 x
Processors and Peripherals
Ll
Task University Program
~ P Compile Design @ search for Partner IP
v P Analysis & Synthesis
B Edit settings o
vl LW
[ —— -
< > < > + Add.
% L]
g an Q| & (A |A <<Filterss 8 Find. | | Find Next
il
= || Type D Message ~
o Quartus Prime Netlist viewers Preprocess was successful. 0 errors, 1 warning
o v
< >
¢
= | System(3)  Processing (20)
-24,-41 100% 00:00:02
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* Project Flow
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e Create VHDL file

* Create a VHDL file for your schematic
* Select File 2 Create/Update = Create HDL Design File

from Current File

-- Copyright (C) 2017 Intel Corporation. All rights reserved.

-- Your use of Intel Corporation's design tools, logic functions

-- and other software and tools, and its AMPP partner logic

-- functions, and any output files from any of the foregoing

-- (including device programming or simulation files), and any

-- associated documentation or information are expressly subject
-- to the terms and conditions of the Intel Program License

-- Subscription Agreement, the Intel Quartus Prime License Agreement,
-- the Intel FPGA IP License Agreement, or other applicable license
-- agreement, including, without limitation, that your use is for

-- the sole purpose of programming logic devices manufactured by
-- Intel and sold by Intel or its authorized distributors. Please

-- refer to the applicable agreement for further details.

-- PROGRAM "Quartus Prime"

-- VERSION "Version 17.1.0 Build 590 10/25/2017 SJ Lite Edition"
-- CREATED "Fri Feb 23 15:52:47 2018"

LIBRARY ieee;

USE ieee.std_logic_1164.all;
LIBRARY work;

ENTITY MyFirstLogic IS
PORT
(
in_A: IN STD_LOGIC;
in_B: IN STD_LOGIC;
out_1: OUT STD_LOGIC;
out_2: OUT STD_LOGIC
);
END MyFirstLogic;

Common

ARCHITECTURE bdf_type OF MyFirstLogic IS

SIGNAL SYNTHESIZED_WIRE_12: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_13: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_14: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_4: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_8: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_9: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_10: STD_LOGIC;

SIGNAL SYNTHESIZED_WIRE_11: STD_LOGIC;

BEGIN

SYNTHESIZED_WIRE_11 <= SYNTHESIZED_WIRE_12 AND SYNTHESIZED_WIRE_13;
SYNTHESIZED_WIRE_13 <= NOT(in_A AND in_B);

SYNTHESIZED_WIRE_4 <= NOT(in_A OR in_B);

SYNTHESIZED_WIRE_12 <= in_B AND in_A;

SYNTHESIZED_WIRE_14 <= in_A OR in_B;

SYNTHESIZED_WIRE_9 <= SYNTHESIZED_WIRE_14 OR SYNTHESIZED_WIRE_12;
SYNTHESIZED_WIRE_10 <= SYNTHESIZED_WIRE_4 AND SYNTHESIZED_WIRE_14;
SYNTHESIZED_WIRE_8 <= SYNTHESIZED_WIRE_14 AND SYNTHESIZED_WIRE_13;
out_2 <= SYNTHESIZED_WIRE_8 OR SYNTHESIZED_WIRE_9S;

out_1 <= SYNTHESIZED_WIRE_10 AND SYNTHESIZED_WIRE_11;

END bdf_type;

© tj
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e Create VHDL file

* Create a component template for your design (DUT)
 Select File > Create/Update = Create VHDL Component

Declaration Files from Current File

-- Copyright (C) 2017 Intel Corporation. All rights reserved.

-- Your use of Intel Corporation's design tools, logic functions

-- and other software and tools, and its AMPP partner logic

-- functions, and any output files from any of the foregoing

-- (including device programming or simulation files), and any

-- associated documentation or information are expressly subject
-- to the terms and conditions of the Intel Program License

-- Subscription Agreement, the Intel Quartus Prime License Agreement,
-- the Intel FPGA IP License Agreement, or other applicable license
-- agreement, including, without limitation, that your use is for

-- the sole purpose of programming logic devices manufactured by
-- Intel and sold by Intel or its authorized distributors. Please

-- refer to the applicable agreement for further details.

-- Generated by Quartus Prime Version 17.1 (Build Build 590 10/25/2017)
-- Created on Fri Feb 23 15:57:28 2018

12

COMPONENT MyFirstLogic

PORT

(
in_A : INSTD_LOGIC;
in_B : INSTD_LOGIC;
out. 1 : OUTSTD_LOGIC;
out. 2 : OUTSTD_LOGIC

);

END COMPONENT;
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* Project Flow
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* Create VHDL file
* Prepare to use the VHDL file

 Remove the BDF file from the project

* In project Navigator — Files, Right click the BDF file and select:
Remove file from project

* Add the created VHDL file to the project
* Select Project - Add/remove files in project = file name ...
e Select the file to add

e Set the VHDL file as the Top-Level Entity

* In project Navigator — Files, Right click the VHDL file and select:
Set as Top-Level Entity

Common 14 © tj
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e Create VHDL file

 Verify your code is synthesizable
e Select Processing -> Start -> Start Analysis & Elaboration

ik Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_Q3_CE1911/Projects/Demo_Projects/MyFirstDE10P roject/MyFirstDE10Project - MyFirstDE10Project

File Edit View Project Assignments Processing Tools Window Help
D = r MyFir: Stop Processing Ctrl+Shift+C 4 9 e s D J L ]
2roject Navigator [=] Files > 5.8 P Start Compilation Crrl+L MyFirstLogic.vhd (£ |IP Catalog og x |
Files ﬂ Analyze Current File L ; | L} A=
BB MyFirstLogic_tb.vhdl Start LY P
BB MyFirstLogic_de10.vhdl Update Memary Initialization File 9 irectory
ot MyFirstLogic.vhd o Compilation Report Ctrl+R > T
.
% MyFirstCounter_tb.vhdl 0 Dynamic Synthesis Report ﬁl Start Partition Merge
b} ; L.
MyFirstCounter_del10.vhdl ' E
who My - Power Analyzer Tool H Start Fitter unctions
%% MyFirstCounter.vhdl Y,
mm Bt sSN Analyzer Tool Jall  Start Assembler
wic clk10Hz.vhdl ce Protocols
— %9 Start TimeQuest Timing Analyzer Ctrl+Shift+T
Receive Compilation Status Notifications ., ry Interfaces and Controllers
Tasks Compilation YE R Ajrr oo rruansae LHuan Lus e E Start EDA Netlist Writer
16 -— VERSION version 17.1.0 | isors and Peripherals
K ~ |17 -— CREATED "Fri Feb 23 15:5!%3 StartDesign Assistant )
Tas 18 sity Program
h ) 19 LIBRARY ieee; L Start Power Analyzer Cirl+shift+P
¥ P Compile Design 20 USE ieee.std_logic_1164.all; it Partner |P
- - 21 Start SSM Analyzer
¥ P Analysis & Synthesis 32 LIBRARY work;
) - 23 A R .
B Edit Settings 24 HEENTITY MyFirstLogic IS o Start Rapid Recompile
= . - vl 25 | PORT
< > € P  Start Signal Probe Compilation Ctrl+Shift+l
x| o 2 Start /O Assignment Analysis
s an B A A (A [F <<Fitens 88 Find... | |d : fone=e i
a Start Check & Save All Netlist Changes
= || Type ID  Message ) i : "
o Quartus Prime Netlist viewers Preprocess was successful. 0 Start Equation Writer (Post-synthesis)
- Start Equation Writer (Post-fitting) v
u
? 8 Start Test Bench Tem plate Writer 2
in
2| System (3} Processing (20) B5| Start EDA Synthesis
Analyzes and elaborates all files in the hierarchy of the current top-level entity 100%: 00:00:02
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e Create VHDL file

* Check all Warni d suceessiu
Check all Warnings and Errors /
Quartus Prime Lite Edition - C:/Tim/GDrive/MSOE/18_0Q3_CE1911/Projects/Dermo_Projects/MyFirstDE10P roject/MyFirstDE10Project - MyFirstDE10Project — [m} =
il i} Y ') Y ) ¥ i}
File Edit Wiew Project Assignments Processing Tools Window Help
O r MyFirstDE10Project | LG P KO DLOL 9

Project Mavigator @ Files Qg = 0 Compilation Report - MyFirstDE10Project bo MyFirstLogic.vhd |IP Catalog pa =

Files A | |Table of Contents | [} X | =

MyFirstLogic_tb.vhdl B2 Flow summary &, <<Filt v it installed IP

MyFirstLogic_de10.vhdl EH Flow Settings Flow Status uccessful JFri Feb * ¥ Project Directory

MyFirstLogic.vhd B2 Flow Non-Default Global Seti | Quartus Prime Version 17.1.0 Build 590 10/ Mo

jabc MyFirstCounter_th.vhdl B2 Flow Elapsed Time Revision Name Flow 'S jrstDE10Project ¥ Library

MyFirstCounter_de10.vhdl R Flow 05 Summary Top-level Entity Name MyFirstLogic Basic Functions

MyFirstCounter.vhdl @ Flow Log Family MAX 10 DsP

clk10Hz.vhdl Analysis & Elaboration Device 10M50DAF484C7G Interface Protocols

W

= O Flow Messages ininafitodets (A= Memory Interfaces and Controllers

Tasks Compilation T =M = © Flow Suppressed Messages || Total logic elements N/A until Partition M Processors and Peripherals
Task ty Total registers N/A until Partition M University Program
v P Compile Design Total pins N/A until Partition M e Search for Partner IP
Total virtual pi A until Partition M
v P Analysis & Synthesis i i N/A until Partition
Total memory bits N/A until Partition M
B Edit settings
v Embedded Multiplier 9-bit elements  N/A until . .
= - you will get a large number of warnings
< > < >«
if you read in the qgsf file — 1 for every
o | Al D A A A | <<Filters> M Eind.. | M8 Find Next .
unused pin
= essage
[ ] Quartus Prime Analysis & Elaboration was successful. 0 errors, 187 warnings

Highlight errors

and warning
|

[3) Processing (15)

100% 00:00:20

Common
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* Create VHDL file
* ALWAYS check your RTL to make sure it makes sense

» Select Tools =2 Netlist Viewers = RTL Viewer

SYNTHESIZED WIRE_12

in_A[ >

SYNTHESIZED _WIRE_8

Y
L/

in_ B[ >

Common

SYNTHESIZED WIRE 14

P
L/

ho [ > out_1

[ > out_2

L

B

* Note —the new design will be optimized

17
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* Project Flow
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Common

* Project Verification
* Create a Test Bench

* Open a new vhdl| design file with the name
MyFirstLogic_tb

* Create a test bench entity and instantiate your design at
the device under test (DUT)

* Create test inputs using the non-synthesizable wait
instructions

19

© tj



* Project Verification
* Create a Test Bench

-— MyFirstLogic_th. vhdl

-- created: 1/26/18
-- by: johnsontimoj
-- rev: 0

-- testhench forlogic example
-- of MyFirstLogic. vhdl

-- brute force implementation

Tibrary ieee;
use ieee.std_logic_1164.all;

entity MyFirstLogic_th is
-- no entry - testhench
end entity;

Common

architecture testbench of MyFirstLogic_tb is

signal IN_A: std_logic;
signal IN_B: std_Togic;
signal ouT_1: std_logic;
signal ouT_2: std_logic;
constant PER: tTime := 20 ns;

COMPONENT MyFirstLogic
PORT

(
in_A : IN STD_LOGI
in_B : IN STD_LOG
out_1 : OUT STD_LOGIC;
out_2 : OUT STD_LOGIC
);

END COMPOMNENT;

20

-- Device under test (DUT)
DUT: MyFirstLogic
port map(
in_A  => IN_A,
in_B == IN_B,
out_1 == QUT_1,
out_2 =»> OUT_2

brute: process -- no sens| Tist allowed

begin

-- Initialize all inputs
IN_A <= '07;
IN_B <= "0";
-— run

wait for PER;
IN_A <= "17;
wait for PER;
IN_A <= '07;
wait for PER;
IN.B == "1";
wait for PER;
IN_B <= "0";
wait for PER;
IN_A <= "17;
IN_B <= "1";
wait for PER;
IN_A <= "07;

IN_B <= "0";

end process brute;
end architecture;
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* Project Flow
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* Project Verification

* Elaborate the design

« With the original vhdl design set as the top level entity (not the
xxxx_tb.vhdl design)

e Select Processing = Start = Start Analysis and Elaboration

* This causes Quartus to check the Test Bench code along
with the original vhdl design

Common 22 © tj



* Project Verification

e Setup the test bench
. Select A55|gnments —> Settings = EDA Tool Settings =

Category:

<

<

<

General
Files
Libraries
IP Settings
IP Catalog Search Locations
Design Templates
Operating Settings and Conditions
Voltage
Temperature
Compilation Process Settings
Incremental Compilation
EDA Tool Settings
Design Entry/Synthesis
simulation
Board-Level
Compiler Settings
VHDL Input
Verilog HDL Input
Default Parameters
TimeQuest Timing Analyzer
Assembler
Design Assistant
signalTap Il Logic Analyzer
Logic Analyzer Interface
PowerPlay Power Analyzer Settings
SSN Analyzer

Device/Board

Simulation
Specify options for generating output file)\ for use with other EDA tools.
Tool name: | ModelSim-Altera
[ Run gate-level simulation automatically afterSempilation

EDA Netlist Writer settings

Eormat for output netlist: | VHDL 100 us

Output directory: |simulation/modelsim \

[ Map illegal HOL characters Oen

Options for Power Estimation

[ Generate Value Change Dump (VCD) file script  Seript Settings:

Des

More EDA Netlist Writer Settings.
NativeLink settings
O None
® Compile test bench: | synchronous_4bit_counter_tb Test Benches.
[ Use script to set up simulation

O script to compile test bench:

More NativeLink Settings. Reset

W Buy Software oK Cancel Apply Help

Common

t Benches
select the end simulation time
select File name

23

: enter the test bench file

and select the test bench file

— Edit Test Bench Settings

Edit test bench settings for the selected test bench.

Test bench name: |MyFirstLogic_tb

Top level module in test bench: |MyFir5’Logic_tb

[ Use test bench to perform VHDL timng simulation

Designins MNA
Simulation period
O Run simulation until all vector sigmuli are used
® End simulation at: SDd ns ¥

Test bench and simulation files

File name: | MyFirstLogic_tb.vhdl

MyFirstLogic

—

Add
File Name Library HDL Version Remove
Default
Up
Down
Properties...
OK Cancel Help

© tj



* Project Verification

e Run the simulation
e Select Tools =2 Run Simulation Tool = RTL Simulation

E !I Mow (300 ns o

|
1 full cycle
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* Project Flow
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* Project Implementation
* Prepare for DE10

* Create a new VHDL File
 MyFirstLogic_de10.vhdl

* Use the DE10 pin names from the gsf file

e or you can use the pin planner
* |[nstantiate your Design

Common 26
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* Project Implementation
* Prepare for DE10

-- MyFirstLogic_del0.vhd]l

-- created: 2/23/18
-- by: johnsontimoj
-- rev: 0

-- DE1D file for random logic
-- of MyFirstLogic.vhd]l

-- using gqsf pin names
—— sSW[0] --=» in_a
-- SW[1l] --= in_B

-- LEDR --> out_1l and out_2

Tibrary ieee;
use ieee.std_Tlogic_1164.al1;

entity MyFirstLogic_dell 1is
PORT(
Sw: in std_logic_vector (1 downto 0);
LEDR: out std_Tlogic_vector (1l downto 0)

L)
end entity;

Common

architecture testbench of MyFirstLogic_dell is

COMPONENT MyFirstLogic

PORT
¢
in_A : IN STD_LOGIC;
in_B : IN STD_LOGIC;
out_1 : OUT STD_LOGIC;

out_2 : QUT S5TD_LOGIC

L)
EMND COMPOMNENT;

DESIGN: MyFirstLogic
port map(
in_A => sSwW(0),
in_B == sw(l),
out_1l == LEDR{0O),
out_2 == LEDR{l)

end architecture;
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* Project Implementation
* Prepare for DE10

* Compile your design
* Check the Compilation Summary

o

Flow Status

Quartus Prime Version
Revision Mame
Top-level Entity Name
Family

Device

Timing Models

Total logic elements
Total registers

Total pins

Total virtual pins
Total memory bits

Total PLLs
UFM blocks
ADC blocks

Embedded Multiplier 9-bit elements

@r‘i Feb 23 17:01:47 2018

17.1.0 Build 530 10/25/2017 SJ Lite Edition
MyFirstDE10Project

MyFirstLogic_del0

MAX 10

10M50DAF4B84CTG

Final

2Y 49,760 (<1 %)

4/|360(1%)

28
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* Project Implementation
* Prepare for DE10

 Check the RTL

MyFirstLogic:DESIGN

SW[1..0] D [0 in_g out 1
1 in_

> LEDR[1..0]

out 2
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* Project Flow

: gl Create Create AK o
Schematic Convert to Verify via Test Verify via DE10 Program Verify via
i i i DE10
Design VHDL RTL Bench simulation 1 DE10
myDesign.bdf myDesign_tb.vhdl myDesign_del0.vhdl|

myDesign.vhdl
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* Project Implementation
* Configure the DE10

e Select Tools -> Programmer
e point to the compiled output file
* start
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* Project Flow
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* Project Implementation
* Configure the DE10

 Validate the design on the DE10 board
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