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PARTINTRODUCTION TO MAX

I N T R O D U C T I O N

Welcome to MAX, the full-custom layout editor from Micro Magic, Inc. MAX 
is more than just a simple layout editor. It is a complete layout environment.

M A X  F E A T U R E S

 Optimized for large databases

 Very Fast Redisplay for Whole Chip Viewing and Editing

 Interactive viewing and editing of hierarchical layout

 Continuous DRC feedback during layout

 Hierarchical and incremental DRC

 Built in netlisting

 Interactive connectivity tracing

 Interactive wiring tool with flylines to show connections not yet 
completed

 Layout generator for gates (using MAX-LS)

 Generators for large regular structures such as SRAMS, ROMs, 
PLA's, and DRAM's (with the optional MegaCell Compiler)

 Smart palette for easy control and feedback on layers

 Full customization and extension via Tcl/Tk scripting language and 
API

 Technology independence via technology description files

 Reads/writes GDSII

 True transparency through layers

 Representational 3D rotation view

 True 3D Thru-Silicon Via Wafer Level editing (using MAX-3D)

 Calibre® interface can display Calibre® DRC errors on layout view 
(Optional feature)

 Runs on Linux and Solaris-10 operating systems.
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This tutorial will introduce you to many of these features. Consult the 
Micro Magic, Inc. MAX User Manual and on-line documentation for further 
information.

T U T O R I A L  O B J E C T I V E S

In this tutorial for MAX Layout Editor, you will learn how to: 

 Understand MAX Layout screen

 Navigate around the layout

 Push into and Pop out of sections of layout

 Check net connectivity

 View DRC errors with MAX or check for Calibre® DRC errors

 Create layout with MAX_LS

 Create and edit custom layout

 Load GDSII layout files

 Create MAX technology files

The tutorials for MAX-3D and MAX-LS (separate licenses are 
required) address specific issues pertaining to these products.

I N S T A L L I N G  M A X

If MAX is already installed at your site, skip this section.

If you are reading this tutorial, you should have already downloaded the 
MMI software. This tutorial assumes that you have already received a 
license file for MAX. The following information is also found in the README 
file that comes with the software.

INSTALLING

MAX

Step 1  Create an installation directory and cd to it.

cd <install_dir>
  PART 1: Introduction to MAX Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7
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Installing MAX
Step 2  Put the release in the install directory. The release file mmi_090831.tgz 
listed below is an example. Use the file which you have downloaded.

cp  <where_ever_you_put_the_release>/mmi_090831.tgz . 
gtar xzvf mmi_090831.tgz

 If you do not have access to gtar (or tar on Linux) but do have 
gunzip, then type:

gunzip mmi_090831.tgz
tar xvf mmi_090831.tar

TIP:
Note that moving the release around with "cp -r" is not a 
good idea, since cp can screw up symbolic links and 
permissions.  Just untar it where you want it to live. 
If you absolutely need to copy it, use "cp -a".

Step 3  Make a symbolic link from <install_dir>/mmi to the <release_dir>. 

ln -s <release_dir> mmi

From the example above the <release_dir> is mmi_090831. You would 
type: 

ln -s mmi_090831 mmi

This allows you to refer to the release simply as mmi.  

When you wish to upgrade to a new release, all you need to do is 
untar the new release into your install_dir and then change the 
"mmi" relative link to point to the new release.

Step 4  Create your initial mmi_local directory as follows:

cp -a mmi/mmi_local.sample mmi_local
  PART 1: Introduction to MAX Tutorial MAX  Layout Environment Ver. 5.7 3
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All site specific data is kept in <install_dir>/mmi_local. That way 
you can upgrade to new releases without losing or having to move 
around local data.  

Step 5  Put the license file where MAX can find it. 
One place MAX automatically looks for the license file is the mmi_local 
directory. The file needs to be called mmi_license.lic

cd mmi_local
cp <license file> mmi_license.lic

Step 6  Start the license server for for floating license:  (If you have a nodelocked 
license, skip this section.)

Nohup mmiserver –f /full_path/mmi_license.lic –l 
mmi_server_log &

 To have the license server automatically start up when the 
machine is rebooted, add the following line to /etc/rc.d/rc.local:

mmiserver –f /full_path/mmi_license.lic –l mmi_server_log &

Step 7  Add path and environment variable info to your .cshrc or .login file. This 
assumes you’re using csh or tcsh. Add the following lines to the file:

setenv MMI_TOOLS <install_dir>/mmi 
set path=(${MMI_TOOLS}/bin.i486-linux $path) #For Linux
set path=(${MMI_TOOLS}/bin.sparc-solaris5.10 $path) #For Sun 
Solaris

Step 8  Source your .cshrc file.

You are now ready to run MAX and start the tutorial.

S T A R T I N G  U P  M A X

Before we get started make sure someone has already installed MAX at 
your site.

INSTALL

TUTORIAL

To run the tutorials, you need to make a personal copy of the MAX 
tutorial example files using mmi_tutorial. 
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Starting up MAX
Step 1  To install the MAX tutorial, type the following at the UNIX prompt:

mmi_tutorial

Make sure that the appropriate tool (MAX) is selected and then click 
on Install Tutorial.  

The default installation directory is “mmi_private/tutorial” in your 
home directory.  You can also select a different directory for 
installation.  Don’t worry if the directory doesn’t exist, the 
mmi_tutorial script will make it if it can.  You can also use this to 
reinstall a clean copy of the tutorial.

Step 2  To start the tutorial, you must first “cd” (change directory) to the 
directory that you installed the tutorial into.  If you used the default 
directory, type:

cd ~/mmi_private/tutorial/max 

Otherwise, replace the above directory with the directory you 
selected.  This directory contains files that you will need to run the 
tutorial.

Step 3  Then to start MAX, simply type: 

max -tech mmi25

A window should come up that looks something like Figure 1-a. 

MAX lets you customize all of the layer colors including the 
background color.

If you are used to working with a black background, you can add "-
bb"  to the end of any MAX technology name.  A separate palette is 
created for a black background with the layer colors adjusted for 
visibility (shown in Figure 1-b). 

 So for this tutorial, to use a black background you would type:

max -tech mmi25-bb   
 

 NOTE: The bulk of this tutorial will be illustrated using MMI default 
colors for clarity and ease of reading.
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TIP:
If you have just installed MAX, the the default technology is 
mmi25, so you would only need to type: max

If you want MAX to come up with a different technology 
by default, you can set the environment variable 
MAX_DEFAULT_TECH.

The rest of this section of the tutorial will go over each element of the MAX 
window.

 Figure 1: MAX Window a) MMI Default Colors; b) Generic Black-
Background Colors
  PART 1: Introduction to MAX Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7
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MAX Screen Layout
M A X  S C R E E N  L A Y O U T

On the very top of the window the title bar should say “max: B UNNAMED”.

“UNNAMED” means that you have not specified the file (cell) you wish to 
edit. The “B” tells you that the cell resides only in the memory buffer.

Next, across the top you should see the menu bar which contains the 
following menu items: File, Edit, View, Tool, Select, Misc, Local, and Help. 
These are pull down menus much like any other application.

Directly to the right of the Help menu is the MAX Message Area. Depending 
on the location of the cursor, it currently says something like “main mode, 
(shift)-BUT-1 selects (more), BUT-2 pans, (Control)-BUT-3 moves 
(stretches) selection”. The MAX Message Area is a sort of mini-help 
feature. It tells you what each mouse button does, and when you have 
pulled down one of the menus from the menu bar, the message area will 
give you a short explanation of what the highlighted menu item does.
  PART 1: Introduction to MAX Tutorial MAX  Layout Environment Ver. 5.7 7
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TIP:
In each of the menus, hotkeys are listed to the right for 
those commands that have hotkeys. You can always find 
out what the current hotkeys are by selecting “Current 
Hot Keys” from the Help menu or using the SPACE hotkey. 
Later in the tutorial we will cover how to change hotkeys.

The remainder of this section of the tutorial goes over each area of the 
MAX window. Refer to the MAX User Manual for a more detailed 
description of the MAX window.

Figure 2 points out the different attributes of the MAX window.

 Figure 2: Items in MAX Window
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MAX Screen Layout
C e l l  L i s t  B o x e s

Down the right side of the window are small List Boxes.

Each List Box displays the cells in a given directory. That directory can be 
the user's “working directory” or a library.

Additional List Boxes can be added (or boxes deleted) by:

 Clicking the left mouse button (Button-1) over the List Box header (the 
horizontal bar saying: demo/tutorial/max in Figure 2), then,

 Clicking the left mouse button (Button-1) on either Make new list box, 
or Close this list box.

The directory the list box points to can also be changed by clicking on the 
desired directory. The directory list includes the directories of all cells that 
are currently loaded into MAX.

By default, no cells are loaded into MAX if not specified on the command 
line. 

AUTOLOAD

CELLS INTO

LIST BOX

To load all of the cells in a paticular directory, you autoload the directory. 
Let’s try this:

Step 1  Hold down the LEFT mouse button over the bottom list box directory and 
select Autoload directory as shown in Figure 3.
  PART 1: Introduction to MAX Tutorial MAX  Layout Environment Ver. 5.7 9



I N T RO D U C T IO N  TO  M A X
MAX Screen LayoutPA R T  1

10
 Figure 3: Autoload Directory from Cell List Box

You should now see the cells drc_test, test_cell, and UNNAMED in the cell 
list box. INV, NAND2, and row are in a different technology (mmi18), so you 
will get a warning message stating this. 

Your max.rc file can specify library directories to be autoloaded at startup 
time using the max_auto_load command.

The max.rc file contains several other useful pieces of information. (See 
the Micro Magic, Inc. MAX User Manual for more details.)
  PART 1: Introduction to MAX Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7
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MAX Screen Layout
TIP:
The commands and variables available to use in your 
max.rc file can be found by selecting Text 
Commands/Variables from the Help menu or using the 
? hotkey. If you click on one of the commands, a definition 
and syntax for that command is listed. If you select a 
variable, a description and the current value is listed. The 
syntax for setting variables is:

set <variable> <value>

You can also adjust the width of the list boxes.

Step 2  Move the mouse pointer over the vertical bar just to the left of the list box. 
The mouse will change to a small horizontal line with arrows on both ends.

Step 3  When the arrows appear, adjust the list box width by holding down and 
dragging with Button-1 to the left or right.

Na v i g a t i o n  Wi n do w

Below the list boxes is the Navigation Window. For large designs, you can 
use the Navigation Window to control the view you see in the main MAX 
window.

The Navigation Window shows a copy of the layout; the brown outline 
represents the boundary of the MAX Window. A red outline represents 
the “Box”. The “Box” is used for editing, and is used to define regions used 
by other commands in MAX. 

TIP:
Holding down the left mouse button (Button-1) and 
dragging out a region in the Navigation Window will 
cause the main window to zoom to that region.
  PART 1: Introduction to MAX Tutorial MAX  Layout Environment Ver. 5.7 11
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The small colored (green, blue, red, cyan, yellow) rectangular buttons on 
the right of the Navigation Window allow you to do several things.

 The topmost button (green by default) steps through the view stack. 
Button-1 zooms backwards in the view stack, Button-3 zooms forward 
in view stack.

 The other buttons allow you to save (remember) and return to views 
— a different view for each. Position the mouse cursor over the 
buttons, and read their function descriptions in the Message Area.

 For example, if you are at a view you know you want to return to, 
simply click the right mouse button (Button-3) on the blue button to 
lock in and remember that location and zoom factor.

 If you later wish to return to that view you simply click the left 
mouse button (Button-1) on that blue button to recall that view.

 The top button always zooms back and forth in the view stack. If you 
desire, you can change the number of buttons and their colors. Both 
the number of view-save buttons, and their colors, can be changed in 
your max.rc file by setting the ZOOM_BUTTONS variable.

CHANGE ZOOM

BUTTONS

Let’s try changing the color of zoom buttons.

Step 1  Exit MAX (hotkey: Ctrl-d).

 Go to the command window (the shell window where you started 
MAX). 

Step 2  Create a max.rc file in your current directory 
(default is ~/mmi_private/tutorial/max).  

Add the following line:

set ZOOM_BUTTONS {blue yellow purple orange green}

Step 3  Restart MAX.  From the shell window, type:

max -tech mmi25

 Your Navigation Window should now look like Figure 4. 
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MAX Screen Layout
 Figure 4: Navigation Window Zoom Buttons - New Colors

HILITE

BUTTONS

The buttons along the left side of the Navigation Window are used to 
highlight items you have selected.  Whenever you have selected objects, 
for example a net, you can highlight them in the layout with the specified 
colors.

LOAD EXAMPLE

LAYOUT

To cover the other portions of the MAX window, we will load in an example 
GDSII file.

Step 1  Exit out of MAX by going to the File menu and selecting Exit or use the 
hotkey Ctrl-d.

The rest of the tutorial will be using the default zoom button colors, 
so if you want MAX to match, you can delete the max.rc file which 
you created earlier.

Step 2  In your shell window (make sure you’re still in the correct directory), type 
the command:

max -tech mmi25 TOP_CHIP.gds

You should see the example layout shown in Figure 5. This block was 
created in MAX using the mmi25 technology and then exported to a 
GDSII file. 
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 Figure 5: Example Layout Loaded into MAX (default colors) 

VIEW

INTERNALS

This GDSII file is made up of a number of SRAMs. The top level cell has 
over 1 million transistors. By default, MAX shows the top level of the 
hierarchy.

Step 3  View all levels of hierarchy by typing the hotkey “i” or selecting “Internals, 
View All” from the View menu.

Your MAX window should now look like Figure 6. All layers and all 
levels of hierarchy are visible.  

Figure 6-b shows this same layout loaded using generic black-
background colors.
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MAX Screen Layout
 Figure 6: Layout of TOP_CHIP.gds with “View Internals, All”: a) 
Default colors; b) Black Background colors

We’ve already covered the Cell List Box. Notice now though that there are 
many cells listed.
  PART 1: Introduction to MAX Tutorial MAX  Layout Environment Ver. 5.7 15
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USING THE

LIST BOX

 Load the cells into the MAX window by clicking the right (Button-3) mouse 
button on the desired cell name. This is noted in the MAX Message Area at 
the top of the window.

Step 1  Try loading cells by clicking on cells with the right (Button-3) mouse button 
in the cell list. If you accidently use the left (Button-1) mouse button, Ctrl-C 
will cancel.

 To get back to the top level, click on TOP_CHIP at the beginning of 
the list with the right (Button-3) mouse button.

TIP:
If you click with the left (Button-1) mouse button on a cell, 
MAX adds an instance of that cell to your current cell. 
We’ll try this later in the tutorial. Don’t worry if you make a 
mistake. You can always undo a command with the 
hotkey u.

D R C  C o n t r o l  a n d  S t a t u s

In the lower left corner is the DRC Status Box. It tells you the current 
status of the continuous interactive DRC which runs in MAX. The DRC 
Status Box also has a small radio button where you can click to turn the 
interactive DRC on or off.  If there are DRC errors, the DRC Status Box 
will report the number of DRC errors. 

Step 1  Because we read in a GDSII file, MAX defaults to drc off. Click on the radio 
button and it may report some DRC errors.

N u m b e r  o f  I t e m s  S e l e c t e d

To the right of the DRC Control and Status area is a box that shows the 
number of items selected. The default is to display “>100” if more than 100 
items are selected. By default any item (gcells, instances, rectangles, etc.) 
selected is displayed. This can be changed in your max.rc file.
  PART 1: Introduction to MAX Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7



I N TR O D U C T IO N  T O  M A X

MAX Screen Layout
TIP:
To find commands and variables, you can select Text 
Commands/Variables from the Help menu or use the ? 
hotkey.  In the search field, if you type in "select", you'll 
find that the variables mentioned above are: 
SELECT_DISPLAY and SELECT_MAX_DISPLAY.

S c r o l l  a n d  Z o o m  b a r s

Scroll Bars are laid across the bottom and right side of the Layout Window 
(and on the right side of the List boxes). These work like the scroll bars in 
most other applications.

Below the bottom scroll bar is the Zoom Bar. Pulling the slider button to 
the left zooms in, and to the right zooms out.

SCROLL WHEEL

ZOOM

In addition, the mouse scroll wheel can be used to zoom in and out. Scroll 
wheel zooming is centered around the cursor position.

Step 1  Try zooming around using the scroll wheel on your mouse. Place the cursor 
in the upper left corner of the cell and move the scroll wheel forward to 
zoom in. Zoom out by moving the scroll wheel down. To get back to the 
full view of the cell, type the v hotkey.

 If you hold down the Shift key while while using the scroll wheel, 
MAX pans left and right.  If you hold down the Ctrl key while using 
the scroll wheel, MAX pans up and down.

U s i n g  t h e  N a v i g a t i o n  W i n d o w

SAVING ZOOM

VIEWS

The Navigation Window can be used to zoom to particular areas, save 
views, and save highlights.

Step 1  In the Navigation Window, drag out a box by holding down the left 
(Button-1) mouse button.  Notice that the main MAX window zooms to this 
area.
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Step 2  Save this zoom by moving over to the colored buttons on the right edge 
and selecting the second button (blue by default, yellow if you changed 
it earlier) with the right (Button-3) mouse button.  Notice that view area in 
the Navigation Window is now surrounded with a (blue or yellow) box.

Step 3  Zoom around to some other areas and save their zoom views using the 
buttons on the right edge of the Navigation Window.  You should see 
something similiar to Figure 7.  Notice that the zoom areas you saved are 
shown in the Navigation Window.  You can return to these zoom views by 
clicking with the left (Button-1) mouse button.

 Figure 7: Zoom Views Saved in Navigation Window

Step 4  Push into one of the smaller cells by clicking on it with the right (Button-3) 
mouse button in the cell list.

Step 5  Select a net by moving the mouse over part of the net and typing the s 
hotkey for Select Net.  (We’ll cover this in more detail later in the tutorial.)  
If you select a large net (i.e. vdd or gnd) a popup will appear that will allow 
you to stop the selection.

Step 6  Save this selection by clicking on the top colored button at the left edge 
of the navigation window with the left (Button-1) mouse button.  Notice 
that the net is now highlighted in yellow (default color) both in the 
  PART 1: Introduction to MAX Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7
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Navigation Window and the main MAX Window.  Repeat this for some 
other nets. 

You should now see something similiar to Figure 8.

 Figure 8: Highlighted Nets Saved in Navigation Window

Notice that if you go back to the top level of the layout by clicking 
with the right (Button-3) mouse button on TOP_CHIP in the Cell List box, 
the zoom view areas are still saved.  The zoom view area and 
highlights are saved for each cell.

 To clear a saved zoom view or highlight, click on the colored 
buttons in the Navigation Window using the middle mouse button 
(Button-2).
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TIP:
Remember, if you ever forget which mouse button to use 
just move the mouse over the area you’re interested in 
(Cell List, zoom buttons on right of navigation window, 
etc.) and read the description in the Message Area at 
the top of the MAX window.

M o u s e  C o o r d i n a t e s  a n d  B o x  S i z e  L o c a t i o n  

In the lower right hand corner the Box Size (in microns) is displayed. (The 
Box is used extensively in the MAX Layout Editor.) This is useful for when 
you select an object and want to know how big it is. It is also used for the 
measure command.

If you click with the left mouse button on the Box Size area, a pop-up will 
appear where you can specify a box or change what information is 
displayed in the Box Size area.  It defaults to displaying the size and area 
of the box.  You can also have MAX display the corners or the origin and 
size.

Just to the left of the Box Size is the Mouse Coordinates display. Mouse 
coordinates are oriented with respect to the top level cell. As you move the 
mouse notice that this info changes.

T h e  P a l e t t e

Along the left side of the window is the Smart Palette. The Smart Palette 
provides many features: 

 It controls which layers are visible.

 It gives feedback on what is currently under the cursor, and what 
is currently selected. 

 It allows you to control which layers can be selected. 

 And finally, it allows you change the color or stipple patterns of 
any of the layers.
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The Smart Palette features are described in detail in the MAX User 
Manual.

W O R K I N G  W I T H  T H E  L A Y O U T  V I E W

Now that you have some familiarity with the MAX window and its’ 
particulars, let’s experiment with moving around and viewing the 
TOP_CHIP layout in detail. 

ZOOMING IN We’re going to zoom in on the layout, and change the layer visibility.

Step 1  Make sure that TOP_CHIP is the edit cell.  Remember, you click on it with 
the right (Button-3) mouse button in the cell list.

Step 2  To clear any highlights you might have, go to the View menu and select 
Clear.

Step 3  Zoom in on the upper left corner of TOP_CHIP. You can zoom in by placing 
the cursor in the upper left corner of the cell and moving the scroll wheel 
up on your mouse.

Step 4  A faster way is to use the z hotkey or select Zoom to Area on the View 
menu. After you type the z hotkey, drag out a box around the upper left 
portion of TOP_CHIP.

 You can also zoom in by placing the cursor in the top left of the layout, 
and typing the hotkey j, or selecting Zoom In on Cursor from the View 
menu.

 Or, you can use the Navigation Window to zoom to this area.

Zoom in until you see something similiar to Figure 9. 
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 Figure 9: Zoomed In View with All Layers Visible

CHANGING

LAYER

VISIBILITY

Currently, all layers are on and visible. Let’s change that.

Step 1  Turn off visibility of m1 by clicking with the LEFT (Button-1) mouse button on 
the blue square to the left of “m1”, as shown here.

 Figure 10: Turn Off Visibility of “m1”

You should now see something similiar to Figure 11. The metal 1 
layer is no longer visible (the bright blue has disappeared).
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 Figure 11: Metal 1 Layer Visibility Turned OFF - No Blue Showing

 If you click with the LEFT (Button-1) mouse button on the box with 
the word 
“-metal-”, the visibility of all metal layers will be turned on. 

 If you click on the label again, the visibility for all metal layers will 
be turned off. We will discuss how the palette can be used to 
control selectability later in this tutorial.

 Click on the “empty” m1 palette square to turn visibility for m1 back on.

CHANGING

LAYER COLOR

Now, let’s try changing the color of the layer m1. First make sure all layers 
are visible. 

Step 1   To access the palette:

 Click with the MIDDLE mouse button (Button-2) on the blue square to 
the left of m1 on the palette, 

OR:

 Go to the File menu, select User Preferences and then Color Editor... 

You should now see the pop-up in Figure 12. 
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 At the top of the pop-up, hold down the LEFT (Button-1) mouse button and 
select  “m1.”

 Figure 12: Editing Layer “m1”

Step 2  To change the color of a layer, you can use the hue, saturation and 
brightness scroll bars or select a color from a list by holding down the LEFT 
(Button-1) mouse button on Colors.

Change the color of metal 1 and notice that it changes interactively in 
the layout.

Step 3  To get back to the original color, click on the Revert... button and then 
click on Done. 

Step 4  To exit the color editor, click on Close.

Refer to the MAX User Manual for more details on editing layer colors and 
styles.
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L a y e r s

Just above the palette are buttons labeled Active:, -cells-, -text- and -all-. 

Active lets you select the active layer for wiring or drawing polygons. 

Cells controls whether or not sub-cells and gcells can be selected.

Text controls the visibility and selectability of text.

All allows you to toggle the visibility or selectability of all layers at the 
same time.

Ge t t i n g H e l p  a n d  t h e  He l p  Me n u

Before we go any further, here is how to get help if you ever need it.

 There are several levels of help available on-line to MAX users. You 
already know about the quick Help feature listed in the MAX Message 
Area. 

 In addition, you can access the complete on-line manual, this 
tutorial, a list of MAX commands and variables and the complete list 
of active hotkeys.

Step 1  Click and hold down the left mouse button (Button-1) on the Help menu. This 
should pop up a sub menu as shown in Figure 13.

 Figure 13: MAX Help Menu
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Help Menu About MAX tells you the version of MAX you are running, the technology 
you are using, etc. 

Unless you have the technology specified in a max.rc file, or you used 
the -tech option when starting MAX,  it defaults to the mmi25 
technology.

Current Hot Keys gives you a list of all available hot keys. You can also hit 
the Space bar to bring up this list.

Text Commands/Variables brings up documentation for the MAX text 
commands and variables. Text commands are useful for writing scripts, 
generators, and other helpful programs. Text commands and the Tcl/Tk 
interface are the MAX API. They allow the user to add their own features 
to the Local and Tool menus.

MAX Manual brings up the MAX manual in your browser. The default 
browser is Firefox. This can be changed in your max.rc file.

MAX Tutorial brings up this tutorial.

MMI Documentation Guide brings up all of the documentation for all of the 
Micro Magic, Inc. software. This document has links to items like the 
Micro Magic, Inc. SUE User Manual, the Micro Magic, Inc MAX User Manual, 
other Micro Magic, Inc. software programs, and even to this tutorial.

Before proceeding you should bring up the Micro Magic, Inc MAX User 
Manual and see what's there. The User Manual is the reference manual to 
MAX and contains lots of information that is not found in this tutorial.

You might also want to look at the menu items just to familiarize yourself 
with what's there.

Te a r  Of f  Me n u s

Sometimes it is convenient to make a menu its own window.

For example:
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Step 1  Going back to the Help menu: when you hold down the left mouse button 
(Button-1) over the Help menu notice that there is a dotted line just before 
the About MAX menu item (not shown in the above figure).

Step 2  If you release the button while over the dotted line the menu will “tear 
off”. The menu then becomes a full-fledged window, like any other 
window on your desktop. The exact behavior will depend upon which OS 
and window environment you are running.

If you are running another window manager, your windows might behave 
a little differently. Consult your window system documentation for more 
details.

The chosen menu will stay pulled-down until you select either a menu 
item, or another menu. 
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PARTVIEWING AND SELECTING 

LAYOUT

This part of the tutorial covers viewing, selecting and editing an existing 
layout. The next part will cover creating new layout.

S I M P L E  V I E W I N G

In the previous section of this tutorial, we covered some basic commands for 
moving around the layout and changing layer color and fill patterns. This 
section will cover how you move around the layout, view the hierarchy, view 
connectivity, edit wires, and measure things.

 You should still have the GDSII file TOP_ CHIP.gds loaded in the MAX 
window. If not, re-load the GDSII file (refer to the previous section).

OK, let’s get started.

Z o o mi n g

Once loaded, there are several methods for zooming into/out of the layout. 
Zoom commands are found in the View menu, and also have hotkeys.

ZOOM IN  Use the zoom hotkey to zoom to an exact region.

 Step 1  Type z. This puts you in zoom mode. Note that the cursor has changed. Next, 
hold down the left mouse button (Button-1) and “drag” out a box 
surrounding the region to which you wish to zoom. When you release the 
mouse, MAX will zoom to this region.

 If you mess up don’t panic. Remember, u will undo any edits you 
have made, and v will always zoom to fit.
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ZOOM OUT

 Step 1  Zoom out by typing Shift-z, or use Zoom Out in the View menu, or use the 
scroll wheel on your mouse (if you have one). You can also use the Zoom 
Bar at the bottom of the MAX window, just below the scroll bars.

ZOOM TO FIT

 Step 2  Type v. The layout will re-center to fit within the size of the layout window.

Zoom In/Out by 2X  One often-used technique for zooming is to use the j hotkey to zoom in by 
a factor of two, centered on the cursor. The hotkey Shift-z can be used to 
zoom out by a factor of two.

Zoom with Scroll
Wheel

 If you are using a scroll wheel mouse, you can zoom in/out by rolling 
forward or backward on the scroll wheel while in the MAX window. 
Zooming will be centered around the point of the cursor.

Zoom Using
Navigation

Window

 Using Button-1 within the Navigation Window itself (lower right corner), 
drag out a box enclosing the desired zoom area. The advantage of using 
the Navigation Window is that it always displays the entire edit cell, so you 
can zoom to a particular area of the layout without having to first zoom 
out.

Using Button-3 within the Navigation Window lets you pan around the 
design.

Pan with
Scroll Wheel

 If you hold down the Shift key while using the mouse scroll wheel, MAX will 
pan to the left as you scroll ‘away, the to the right as you scroll ‘towards’ 
yourself.

If you hold down the Ctrl key while using the scroll wheel, MAX will pan up 
and down.

S e l e c t i n g L a y o ut

After your layout is loaded, MAX offers several different selection options. 
Using these options for an object (cell) or rectangle, you can:

 Select individual rectangles of the layout

 Select cells or layers within the layout

 Select nets and trace connectivity
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When MAX is in main mode (the default), dragging out a region while 
holding down Button-1 will select whatever is contained within that box 
when you release the button, highlighted in white.

LOADING A

SMALLER CELL

First, to simplify things, we will load and view a smaller cell.

 Step 1  Go over to the Cell List Box on the right side of the MAX window and click 
with BUTTON-3 on MMI_SRAM_row_128x2.

TIP:
Remember, if you click with Button-1, MAX will 
instantiate MMI_SRAM_row_128x2 in your current 
layout.

Dont’ worry, you can always use the undo (hotkey: u) 
command. If the cell has not been placed yet, Ctrl-c will 
abort the command.

You should now see something similar to Figure 14.

 Figure 14: Cell MMI_SRAM_row_128x2 Loaded
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 Step 2  Zoom in on the left half of this cell. Type the z hotkey and drag out a box 
using Button-1. You should be looking at something similar to Figure 15.

 Figure 15: Zoomed In on MMI_SRAM_row_128x2

SELECT USING

HOTKEY

Now we will select cells through the hierarchy of the layout.

 Step 3  Move your mouse to the center of the MAX window as shown in Figure 15 
(above). Type the hotkey f to select a cell.

 You should now have the cell mmi_sram_cell selected.

 If you look in the Message Area at the top of the MAX window, you 
should see a message like “selected cell is type mmi_sram_cell 
(MMI_SRAM...)”.

This tells you which cell has been selected and shows the 
hierarchicah path to the cell inside the parentheses.
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You should see something similar to Figure 16. It doesn’t matter if 
you have a different mmi_sram_cell selected than is shown in the 
figure.

 Figure 16: ‘mmi_sram_cell’ Selected in MMI_SRAM_row_128x2

 Step 4  Without moving the mouse, type hotkey f once more. You should now 
have the cell MMI_SRAM_CELL_4_128x2 selected.

 If you have moved the mouse, you will see mmi_sram_cell selected 
again. That’s OK, just type the f hotkey a second time without moving the 
mouse.

 Depending on where you placed the cursor initially, you might have 
selected the mmi_sram_cell adjacent to the first one. Simply type f for a 
3rd time and MMI_SRAM_cell_4_128x2 will be selected.

 Notice the Naviagtion Window shows you where this particular cell (dark 
red outline) is located in relation to the current cell and the zoomed area 
of the cell (light brown rectangle).

 Step 5  Type f (select cell) another time without moving the mouse to select 
MMI_SRAM_half_row2_128x2. You should see something similar to 
Figure 17.
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 Figure 17: MMI_SRAM_half_row2_128x2 Selected

The first time you use the Select Cell command (hotkey: f) it finds the cell 
at the bottom of the hierarchy. The next time it moves up to the next level 
of hierarchy. If two cells overlap at the same level of the hierarchy and you 
position the mouse over the region that overlaps, Select Cell will highlight 
the first cell, then the second cell, and then move up the hierarchy. You 
may have seen this happen when selecting the cells.

SELECT USING

THE BOX

You can also select cells by dragging out a box with Button-1 that includes 
some part of the cell.

 Step 6  Try selecting a cell by dragging a box with Button-1 around part of the 
layout. You should see something similar to Figure 18.
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 Figure 18: Selecting by Dragging Out a Box

Notice that the Message Area at the top of the MAX window says 
“selection contains 2 cells” and the Select Box at the bottom of 
the window says “select:2”. If only one cell has been selected, then 
the name of this cell is listed in the Message Area. Dragging out a 
box only selects cells at the current level of hierarchy.

 Another way to select a cell is to click over it with Button-1. This method 
only selects cells at the current level of hierarchy. If you want to select 
cells throughout the hierarchy, you need to use the Select Cell (hotkey: f) 
command.

SELECT BY

NAME

Additionally, you can select cells by name.

 Step 7  In the Select menu, go to Select by Name... or use the n hotkey. You’ll see 
a pop-up similar to Figure 19.
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 Figure 19: Select By Name Pop-up

TIP:
Most pop-ups in MAX have a Help button. Clicking on the 
Help button opens an item-description pop-up.

 Step 8  Click on the Cell Def toggle button. We’re going to be selecting cells by 
the name of the cell definition (e.g.: mmi_sram_cell) and not by the 
instance name.

 Step 9  Hold down Button-1 on the pull down list to the right of Enter Cell Def 
Name:. Select MMI_SRAM_wl_buf2_128x2.

 Click on the Zoom to selected toggle button. Now click on Done and you 
should see something similar to Figure 20.
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 Figure 20: MMI_SRAM_wl_buf2_128x2 Selected by Name; Zoomed out

There are two cells selected. MAX zoomed out so that both cells are 
visible.

S e l e c t i n g P o l y g o n s  a n d  C o n t r o l l i n g  Wh at  I s  S e l e c t e d

In this section we will now look at how to select rectangles or polygons. 
We will also look at how you know which layers have been selected and 
how to control what layers are selectable. If you are trying to select a 
rectangle on m1 and there are other layers on top of it, you can turn off the 
selectability of the other layers. That way you can select just the m1 
rectangle.

SELECTING

POLYGONS

First, we need to push into a cell containing layout, and not just 
instances of cells. We will push into the bottom level cell mmi_sram_cell.

 Step 1  Go back to the left side of the layout and use the Select Cell command 
(hotkey: f) to select the same mmi_sram_cell as we did earlier.

 Step 2  Push into the cell by using the Push into Cell command (hotkey: e) in the 
View menu. You should now see something like Figure 21.
  PART 2: Viewing and Selecting Layout Tutorial MAX  Layout Environment Ver. 5.7 37



VI EW I NG  A N D  S E LE C T IN G  L A Y OU T
Simple ViewingPA R T  2

38
 Figure 21: Push Into View of MMI_SRAM_cell

 Step 3  Drag out a box using Button-1 tha encloses the upper left corner of the 
cell. You should see something similar to Figure 22.

 Figure 22: Selecting Rectangles by Dragging Out a Box
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The number of rectangles selected will most likely differ from the 
example above. The Message Area should say “selection contains 
rect.” Notice that the Select Box at the bottom middle of the MAX 
window (to the right of the Zoom sliders) lists how many things are 
selected. In Figure 22 above, 19 rectangles have been selected.

If your box included the vdd text, then the Message Area will say 
“selection contains rect. text.”

 Step 4  Look at the palette along the left side of the MAX window. Notice that 
some of the layer names are now red. This indicates that rectangles on 
that layer have been selected.

On the far left of the palette, notice the red indicator rectangles 
(“LEDs”) next to some of the layers. These show whenever the cursor 
is currently hovering over that layer.

 You can also select objects by clicking once over them with Button-1.

 Step 5  Move the mouse so that the cursor is over the upper left contact, as 
shown in Figure 23.

 Figure 23: Mouse Cursor Positioned Over Upper Left Contact
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Clicking Button-1 on a rectangle selects that particular rectangle.

 Click once with Button-1 at the location shown in the above figure to see 
something similar to Figure 24.

 Figure 24: ‘m2’ Rectangle Selected

You should have selected an m2 rectangle. The Message Area should say 
“selected rectangle on layer m2”.

When there are multiple layers under the mouse cursor, clicking more 
than once without moving the mouse will select each layer in turn. You 
can keep clicking until the one you want is selected.

MAX starts with the “highest” layer. For example, it would select m3, then 
v23, then m2, etc.

 Step 6  Without moving the mouse, click Button-1 two more times. You should now 
see something similar to Figure .
  PART 2: Viewing and Selecting Layout Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7



V IE W IN G  A ND  S E L E C T ING  L A Y O U T

Simple Viewing
 Figure 25: “m1” Rectangle Selected

SELECTING

USING CURSOR

PROBE

Another way to select a rectangle on a particular layer is to use the Cursor 
Probe command (hotkey: l - ell; lower-case L). This opens a pop-up window 
listing everything underneath the cursor.

 Step 1  Clear everything that is selected using the Clear Selection command 
(hotkey: c) from the Select menu.

 Step 2  Move the mouse back to the same location shown in Figure 25 above. 
Type the Cursor Probe hotkey l (ell) and a pop-up like Figure 26 should 
appear.
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 Figure 26: Cursor Probe Results for Layers Under Selection

 Step 3  As you click on each of the layers in the list, that layer will be selected. 
Click on the layer a second time to turn off the selection. Refer to the MAX 
User Manual for more information on the Cursor Probe.

S e l e c t i n g N e t s

MAX can trace connectivity through vias and contacts to interactively 
show everythig connected to a net. We’ll first see this using the 
mmi_sram_cell.

SELECTING A

NET

 Step 1  Place the cursor in the same location shown in Figure 23 and type hotkey 
s, or choose Select Net from the Select menu. You should now see 
something like Figure 27.
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Simple Viewing
 Figure 27: Select Net on ‘mmi_sram_cell’

MAX will automatically select the entire net that is connected to the 
m2 rectangle that was under the cursor, and will also display the net 
name, if known, in the MAX Message Area. The net name(s) are 
taken from any Text (labels) attached to the net. For the above net, 
the net name is gnd.

Notice in the palette on the left that some of the layer names are now 
in red. This indicates that the selected net contains these indicated 
layers.

 Step 2  Clear the selection by typing the hotkey c.

 Now we will use the Cursor Probe to select the net. Move the cursor once 
more to that same location and type l (ell - lower-case “L”). In the pop-
up, double click with Button-1 on “rect: m2” and you should see the same 
net highlighted.

 Step 3  Close the Cursor Probe pop-up.
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C o n t r o l l i n g  L a y e r  S e l e c t a b i l i t y

Now we will load a simple test cell that will make it easier to see how 
selecting works.

 Step 1  Go to the File menu and select Open.

 Once the pop-up form appears, click to select “test_cell.max”.

 Click OK. You should now see Figure 28.

 Figure 28: Loaded MAX File ‘test_cell’

 Step 2  Zoom in on the lower left corner of the cell so that you see something 
similar to Figure 29.

 Remember, to zoom in you can use the z hotkey and then drag a box 
around the desired area.
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Simple Viewing
 Figure 29: Zoomed In on ‘test_cell’

 Step 3  Place the cursor so that it is over both the left side diffusion and m4, as 
shown in Figure 30. Click Button-1 once and notice that an m4 rectangle 
has been selected.
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 Figure 30: Selected ‘m4’ Rectangle in “test_cell.gds”

For this example, the nfet has been glattened and is no longer a gcell. 
(Gcells are discussed later in this tutorial.)

TURNING OFF

SELECTABILITY

To select the ndif rectangle, you could continue clicking at the same 
location until the piece of ndif is selected. 

Another way is to turn off the selectability of some of the layers.

 Step 4  Move over to the palette along the left side of the MAX window. Click 
with Button-1 on the “metal” button to turn off visibility of the metal layers. 
It may still show you where the piece of m4 is that you previously selected.

 Step 5  Turn visibility of all the metal layers back on by clicking again with Button-1 
over the “metal” toggle button.

 Step 6  Now click with Button-3 on the “metal” toggle. The palette should look like 
Figure 31.

Notice that all of the metal layer names are greyed out. This means 
that you cannot select anything on that layer. if the piece of m4 is still 
selected, the name “m4” will show in red on the palette.
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 Figure 31: Palette Showing Metal Layers Selectability Turned Off

 Step 7  Now click Button-1 in that same previous location (refer to Figure 30).

A rectangle of ndif should now be selected, as shown in Figure 32. 
Because the selectability of all metal layers has been turned off, MAX 
finds the next layer under all of the metal layers, That layer name is 
shown in red in the palette. Remember that the red “LED” rectangles 
on the far left of the palette indicate which layers are underneath the 
cursor.

-metal- toggle button: Click with Button-3 to turn off 
selectability of all metal layers (buttons turn grey)

Red text showing m4 layer selected 

Grey buttons indicate selectability 
of all metal layers is off
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 Figure 32: Rectangle of ‘ndif’ Selected

 Step 8  Turn back on the selectability of the metal layers by clicking again with 
BUTTON-3 on the “metal” toggle button. The layer names will no longer be 
greyed out.

S e l e c t i n g N e t s ;  L ay e r  S e l e c t a bi l i t y ;  E d i t i n g Wi r e s

We have selected single and multiple rectangles. Now we will look at how 
to select nets to help you investigate connectivity.

ZOOMING IN

ON SELECTION

 Step 1  Zoom back out to view the entire test_cell. Remember, you can use the 
v hotkey (centered zoom-to-fit).

 Step 2  Zoom in on the right side of test_cell. You should now see something 
similar to Figure 33.
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Remember that you can also use the Navigation Window to zoom in 
to the same area.

 Figure 33: Cursor Positioned Over ‘m3’ in “test_cell”

 Step 3  Place the cursor over the middle left m3 rectangle as shown above. Now 
type the Select Net hotkey: s.

You should now see something like Figure 34.
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 Figure 34: Select Net at Cursor Position Over ‘m3’

Notice that the entire net is selected from gate to gate. The information on 
how layers connect is specified in the MAX technology file. The 
technology file is also where the layer names, colors, fill patterns, and 
DRC rules are specified. We’ll cover a couple of ways to generate a 
technology file in a later section.

 Step 4  Look at the palette, as shown in Figure 35. Notice that there is a red LED 
rectangle to the left of m3. This tells you that the cursor is currently over a 
piece of m3. All of the metal names, as well as poly, nfet, and pfet names 
are highlighted in red. This indicates that rectangles on those layers have 
also been selected.
  PART 2: Viewing and Selecting Layout Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7



V IE W IN G  A ND  S E L E C T ING  L A Y O U T

Simple Viewing
 Figure 35: Highlighted Layer Names in Palette Indicate Selected 
Layers

TIP:
A nice feature often used for debugging is that when MAX 
selects a net, the name of all the text labels on that net 
are displayed in the MAX Message Area at the top. For 
example, if you select a VDD net and the names VDD and 
GND both appear, you know you have a problem.

EDITING WIRES One of the features of MAX is the ability to easily edit wires while ensuring 
that the appropriate vias are moved along with the wire segment.

 Step 5  Type the Ctrl-w hotkey or select Edit Wire from the Edit menu. Hold down 
Button-1 over the right middle segment of m2, as shown in Figure 36. Drag 
the mouse to the right and notice that the associated vias move along 
with the segment of m2.

Red LED and text showing cursor over m3 layer and m3 
selected

Names of Layers in red indicates there are rectangles
on these layers selected, but cursor not over these layers.
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 Figure 36: Editing ‘m2’ Wire in “test_cell.max”

USING LAYER

SELECTABILITY

We will now look at the ways you can use layer selectability to control 
which nets are selected.

 Step 1  Use the Pan hotkey “->” (KP_RIGHT) to pan the layout over until you see 
something similar to Figure 37.

KP_RIGHT is the right arrow key on the number key pad to the right of 
the main key pad. If your key pad is mapped differently, you can 
always use the Pan scroll bar at the bottom of the MAX window, or 
mouse Button-3 in the Navigation Window.

TIP:
You can also pan left and right by holding down the Shift 
key while using the scroll wheel on your mouse. If you hold 
down the Ctrl key, MAX will pan up and down.

 Step 2  Move the cursor over an area where m4, m3 and m1 overlap, as shown in 
Figure 37 below.
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 Figure 37: Cursor on Overlapping Layers ‘m4’, ‘m3’ and ‘m1’

 Step 3  Click on the Select Net hotkey: s. You should see something like Figure 38.

 Figure 38: Select Net at Cursor Position
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 MAX selected the net containing m4.

 Typing the s hotkey a second time at the same location selects the net 
containing m3 below.

 Typing the s hotkey a third time selects the net containing m1.

TURNING OFF

SELECTABILITY

If you know that you want to select the net containing m1, you can turn off 
the selectability of the other metal layers. This way you only have to Select 
Net one time.

 Step 4  On the palette, click with Button-3 on the layer names m4 and m3. These 
layer names should now be greyed out.

 Move the cursor over the same location as shown in Figure 38 above. 
Type the s hotkey and notice that the net cotaining m1 was selected. 
Remember, you can always look to see which layer names in the palette 
are displayed in red to find selected layers.

B I G G E R  D E S I G N S  A N D  H I E R A R C H Y

S ho w / Hi de  I n t e r n a l s

In this section, we will look at ways to view the layout through the 
hierarchy.

HIDING

INTERNALS

 Step 1  Load TOP_CHIP again into the MAX window by clicking at the beginning 
of the Cell List Box with Button-3.
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TIP:
Remember that if you click with Button-1, MAX will 
instantiate TOP_CHIP in your current cell. Don’t worry, 
you can always use the undo (hotkey: u) command.

If you have not restarted MAX, then all layers and all levels of 
hierarchy are visible.

 Step 2  Type the Internals, Hide All hotkey: h. This hides all of the internals of all the 
cells so you are viewing only the top level instantiations of cells.

You should now see something similar to Figure 39.

 Figure 39: Hiding Internals of ‘TOP_CHIP.gds’

One way of looking at the hierarchy of the layout is to view internals of the 
entire cell or selected subcells. At the beginning of this tutorial we already 
viewed internals of the entire cell using the hotkey i (Internals, View All from 
the View menu).

Now we’ll look at viewing the internals of selected cells.
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VIEWING

SELECTED CELL

INTERNALS
First we will look down at the next level of hierarchy of a cell.

 Step 1 Zoom in on the upper left corner of TOP_CHIP as shown in Figure 40.

 Figure 40: Zoom In On Upper Left of ‘TOP_CHIP.gds’

 Step 2  Select the upper left MMI_SRAM128x2 cell by clicking on it with Button-1.

 Type Shift-i, or select Internals, Show Cell from the View > Internals, Misc. 
menu.

 You should now see something similar to Figure 41. (Typing Shift-h will Hide 
Internals for the cell.)
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 Figure 41: Viewing Internals fo ‘MMI_SRAM128x2’ Cell

You are now looking at the top level cells for the upper left MMI_SRAM128x2 
cell.

 Step 3  To veiw all internals for the MMI_SRAM128x2 cell, select Internals, View Area 
frim the View > Internals, Misc. menu.

TIP:
If you find that you are using a command often that 
doesn’t currently have a hotkey, you can edit the hotkeys 
and add a hotkey for this command.

You should now see something similar to Figure 42. All levels of hierarchy 
for the upper left MMI_SRAM128x2 are visible.
  PART 2: Viewing and Selecting Layout Tutorial MAX  Layout Environment Ver. 5.7 57



VI EW I NG  A N D  S E LE C T IN G  L A Y OU T
Bigger Designs and HierarchyPA R T  2

58
 Figure 42: Viewing All Area Internals of Cell ‘MMI_SRAM128x2’

VIEW

INTERNALS OF

HIERARCHY

If you want to continue viewing down another level of hierarchy, you can 
use the Internals, View More command.

 Step 4  First hide all of the internals by typing the h hotkey.

 Type hotkey Ctrl-i 3 times. You should now see something similar to 
Figure 43.
  PART 2: Viewing and Selecting Layout Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7



V IE W IN G  A ND  S E L E C T ING  L A Y O U T

Bigger Designs and Hierarchy
 Figure 43: Internals, View More of Cell ‘MMI_SRAM128x2

 Step 5  Another way to view levels of hierarchy is to select Internals, View Levels 
from the View menu.

 The easiest way to use this feature is to tear off the sub-menu. Do this by 
clicking with Button-1 on the dotted line at the top of the sub-menu. You 
should now see the pop-up in Figure 44.
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 Figure 44: Internals, View Levels of Cell ‘MMI_SRAM128x2

 Step 6  Click on the different levels and notice the results.

P u s h &  P o p

In addition to the zoom and internals features for really getting to know 
your layout, you can Push into or Pop out of cells. Pushing into goes deeper 
into the hierarchy one level at a time; popping out moves back up through 
the hierarchy.

P u s h i n g  I n t o / P o p p i n g  O u t  O f  C e l l s

TO PUSH IN

 Step 1  You should still have TOP_CHIP loaded in MAX. View all levels of hierarchy 
using the i hotkey.

 Step 2  Select a cell using f, or Select Cell from the Select menu.

 Step 3  Now type e, or select Push into cell from the View menu.
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TO POP OUT You will now be viewing just the cell you selected. To get back to the top 
level of hierarchy, you can pop up to that level.

 Step 4  Type Ctrl-e or select View > Pop out of Cell to “pop up” a level.

 You can continue using e or Ctrl-e to go further into or out of levels.

EDIT IN PLACE If you want to edit a cell and also see all of the layout around it, you can 
edit a cell in place.

 Step 5  From the top level again select a cell using the f hotkey. Now type Shift-e 
or select View > Edit Cell or Object in Place.

The cell you are editing in place will show darker than the 
surrounding layout, as demonstrated in Figure 45.

 Figure 45: Edit Cell in Place

C e l l  H i e r a r c h y  B r o ws e r

Yet another way to explore the hierarchy of your chip or block is to use 
the Cell Hierarchy Browser.
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BROWSING

CELL

HIERARCHY

Make sure you are back at the top level of TOP_CHIP. You can always RIGHT 
click (Button-3) on TOP_CHIP in the Cell List at the right.

 Step 1  Select Display Hierarchy... from the View menu, or type Shift-l (ell). You 
should now see a pop-up like Figure 46.

 Figure 46: Cell Hierarchy Pop-up

 If you click with Button-1 on any of the cells in the hierarchy browser, all 
instances of the cell at that level of hierarchy will be selected in the layout 
and you will be zoomed out to fit all of those instances.

 Step 2  Click (Button-1) on MMI_SRAM_bottom4_128x2 toward the top of the Cell 
Hierarchy Browser list as shown in Figure 47.

The ‘2’ in brackets, to the right of MMI_SRAM_bottom4_128x2, indicates 
there are 2 of these cells at this level of hierarchy. Because there are 
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16 copies of MMI_SRAM128x2, there will be 32 MMI_SRAM_bottom4_128x2 
cells selected, as shown in Figure 47.

 Figure 47: Selecting ‘MMI_SRAM_bottom4_128x2’ in Cell Hierarchy 
Browser Shows 32 Selected Cells in Layout

If you want to zoom to each of them, you can use the Selection Probe.

 Step 3  With the cells still highlighted, click on the Select Box at the bottom 
middle of the MAX window as shown in FXX. It should say “select: 32”.
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 Figure 48: Click on Select Box to Open Selection Probe Pop-up
]

 Step 4  Click on one of the cells (Button-1) or click on the Zoom to Next button to 
step through each of the mmi_sram_clk_buf cells. You should see 
something similar to Figure 49. When you are done, click on Close.
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 Figure 49: Zoom to Next Cell in Selection Probe

 Step 5  On the Cell Hierarchy Browser, RIGHT-click (Button-3) on 
MMI_SRAM_bottom4_128x2.

 If you can’t find the Cell Hierarchy Browser, you can always select View > 
Display Hierarchy, or type the hotkey Ctrl-l (ell). You should see something 
similar to Figure 50.

 When you are done, click on Close.
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 Figure 50: ‘MMI_SRAM_bottom4_128x2’ Cell Loaded Into MAX from 
Cell Hierarchy Browser

Next, we’ll see how MAX handles interactive real-time DRC, a useful and 
powerful feature.

V I E W I N G  D R C  E R R O R S  I N  M A X  A N D  W I T H  T H E  C A L I B R E ®  
I N T E R F A C E

MAX includes interactive DRC (design rule) checking. You can step 
through DRC errors and fix them on the fly. MAX also includes an 
interface to the Mentor Graphics’ Calibre® DRC checker where MAX is 
used to step through and view each of the DRC errors. You can 
interactively correct the DRC errors as you go. MAX reads in the 
<cell_name>.drc_maskdb results from a Calibre® run.
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MAX can also interface with Calibre® RVE. For information on how to use 
this interface, refer to the MAX User Manual.

VIEW MAX

DRC ERRORS

We’ll load a small text cell which has some DRC errors and for which 
we’ve already run Calibre®.

 Step 1  Select Open... from the File menu. This will open a layout file that is in the 
MAX format.

 Step 2  Select drc_text.max and click on OK. You should now see something like 
Figure 51.

 Figure 51: Loading ‘drc_text.max’ File

Notice that MAX displays DRC errors as dotted white rectangles. 
(DRC colors can be easily modified; we’ll cover this in the section 
Modifying Palette/Layer Styles within MAX (page -148).)

 Step 3  Look at the box at the lower left corner of the MAX window and notice 
that it says “drc 11 errors”. This means there are 11 DRC errors in this cell.

There are a number of ways to look at the DRC errors. Let’s say 
you’re interested in finding out what a specific DRC rectangle 
  PART 2: Viewing and Selecting Layout Tutorial MAX  Layout Environment Ver. 5.7 67



VI EW I NG  A N D  S E LE C T IN G  L A Y OU T
Viewing DRC Errors In MAX and with the Calibre® InterfacePA R T  2

68
represents. You can daw a box around that error and ask MAX what 
it represents.

 Step 4  Type the hotkey b for menu select Misc. > Make/move Box. Hold down 
Button-1 and drag a box around the lower left DRC error, as shown in 
Figure 52.

 Figure 52: Dragging Box Around Lower Left DRC Error

TIP:
You could also have simply dragged out a box around the 
DRC error without using the Make/move Box command, 
but this would also have selected the layout under the 
box.

 Step 5  Type hotkey Shift-y, or menu select Misc. > Explain DRC under Box. In the 
Message Area at the top of the MAX window you should see:

DRC: m1 minimum spacing - 0.32 um.
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 If you drag a box around multiple DRC errors, the MAX Message error will 
display the number of DRC errors under the box and tell you to look at the 
MAX command window (the shell window from which you started MAX) 
for details.

 Step 6 Another way to find out what the DRC errors are is to step through them.

 Type hotkey Shift-n or select DRC Find Next Error from the Misc. menu. MAX 
will zoom in on a DRC error and display the text of the error in the MAX 
Message Area.

 Continue to type Shift-n to step through the remaining DRC errors.

The Shift-n hotkey can be very useful if you’re looking at a reasonably 
large block and MAX informs you of a DRC error (bottom left corner 
of the MAX window). Sometimes you can’t see where the error is if it’s 
small, and you can use Shift-n to find the DRC error.

FIXING DRC

ERRORS

As you are stepping through the DRC errors, you can fix them on the fly.

 Step 1  Step through the DRC errors using the Shift-n command until you see “DRC 
#1” in the Message Area, and you see something similar to Figure 53.

 Figure 53: Using ‘Shift-n’ to Find Error ‘DRC #1’
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 Step 2  Type hotkey a or menu select Edit > Edit Edge. Notice the cursor has now 
changed to a hand with a pointing finger, as shown in Figure 54.

 Move the cursor near the upper edge of the poly. Hold down Button-1 and 
drag the mouse upwards (thus moving the poly) until the DRC error 
disappears.

 Figure 54: Editing Edge To Remove DRC Error

 Step 3  Let’s fix another DRC error. Type Shift-n until you see “DRC #8” in the 
Message Area. You should see something similar to Figure 55.
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 Figure 55: Using ‘Shift-n’ to View DRC Error #8

 Step 4  We’ll use the Edit Wire command to fix this DRC error. 

 Type the hotkey Ctrl-w or menu select Edit > Edit Wire.

 Move the cursor over the lower left m1 segment as shown in Figure 55, 
above. Hold down Button-1 and slide the mouse to the left until the two 
vertical pieces of m1 are aligned, as seen in Figure 56 below.
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 Figure 56: Using the ‘Edit Wire’ Command to Fix DRC Errors

You should now only have 5 DRC errors left. Look at the DRC status 
box at the lower left corner of the MAX window.

DRC

FEEDBACK

WINDOW

We’ll now look at a third method to step through your DRC errors using 
the DRC Feedback window.

 Step 1  Go to the Misc. menu and select DRC Results, or type hotkey Ctrl-y. A pop-
up like Figure 57 will open.
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 Figure 57: DRC Feedback Pop-up

The DRC Info section of the pop-up may say:

DRC #8
No such DRC error.

Remember, we just fixed DRC error #8, so it doesn’t exist any more. 
The DRC Feedback window comes up showing the most recent DRC 
error you were viewing.

 Step 2  Click on the Next Error button to step through each of the remaining DRC 
errors and fix them as we did earlier.

 Close the DRC Feedback window.

VIEWING

CALIBRE® DRC

ERRORS

MAX does not check all DRC rules: for example, antenna rules or wide 
metal rules. To check for these errors, you need to use an external DRC 
checking tool. MAX includes an interface to Mentor Graphics’ Calibre® 
tool.

For this tutorial we assume you don’t have the Calibre® interface 
available, so we’ve already run Calibre® on this cell.

 Step 1  Since Calibre® was run on the cell with all of the DRC errors, we need to 
first get back to the original cell. Either type the undo hotkey u multiple 
times to step back through all DRC errors, or go to the File menu and 
select Revert to Last Saved.
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 Click Yes when asked:
“Really throw away changes to cell ‘drc_test’?”

 Step 2  Now go to the Tool menu and select Calibre DRC... to open a form like 
Figure 58.

 Figure 58: Calibre DRC... Pop-up Menu

If the Calibre® interface is set up at your site, you can run Calibre® 
directly from MAX and then view the results. For this example, Calibre® 
has already been run.

 Step 3  Select View feedback from file and then click on Done. You should now 
see a pop-up form like Figure 59.

 By default, MAX looks in the same directory as your cell to find the 
Calibre® results file. If it is named <cell_name>.drc_maskdb, then it will be 
found automatically. Otherwise, you can specify the file using the Find... 
button.

CAUTION:
If you forget to select View feedback from file, the 
Calibre® output file could get overwritten. If that happens, 
you can click on the Find button and specify the Calibre® 
results file as: drc_text.drc_maskdb.save.
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 Figure 59: Viewing Calibre® Feedback Pop-up Form

The form lists each of the DRC errors reported by Calibre®. Clicking 
on the error types expands or collapses that error.

 Step 4  Click on Next Error. The MAX window should now look similar to Figure 60, 
with the DRC error polygons shown in brown.

 Figure 60: DRC Pop-up Showing Error Listed, and MAX Window 
Zoomed In on Error
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MAX automatically zooms you in on the first DRC error. You can also 
click on a specific DRC error in the list and MAX will zoom to that 
error location. In the above example, error #2 has been selected.

Refer to the MAX User Manual for more information on the Calibre® 
DRC interface.

CHANGING

COLOR OF DRC

ERRORS

If you don’t like the color used to display the location of DRC errors, 
you can always change it in the Color Editor.

 Step 5  From the File menu select User Preferences > Color Editor...

 At the top of the editor panel, click and hold down the button displaying 
Edit layer “nw” and then select annotation from the list, as shown in 
Figure 61. 

 Hold down the Colors button and select yellow, the last color in the list. 

 Click on Close in the Color Editor.

 Figure 61: Color Editor: “annotation” Layer Changed to Yellow
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You should now see a display similar to Figure 62, with the DRC error 
polygons showing yellow.

 Figure 62: DRC Error Color Changed to Yellow

In this fashion, you can customize the MAX display colors as desired, and 
see the changes instantly.

Now we’ll go on to try something really fun.

V I E W I N G  L A Y O U T  I N  3 D

Yes, it’s true! MAX (and MAX-LS) provide a symbolic three-dimensional 
view of your layout, generated real-time, on the fly. While there is no true 
commercial use for a three-dimensional view yet, it can be quite 
informative to see how layers of a chip actually interact. (Please note this 
is a VIEW only. True 3D Layout and Editing are part of the MAX-3D 
Layout Editor.)
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ISSUE:

Please keep in mind that this is a symbolic or 
representational 3D view, not an actual one, and meant 
more for informative purposes. 

In MAX and MAX-LS, Z-axis dimensions are estimated and 
can be specified in your tech file if needed. Distances 
between layers are also estimated in the 3D view. Refer to 
the MAX User Manual for information about setting Z-axis 
dimensions and coordinates.

The 3-D View is not as fast as the standard layout view. Smaller cells 
work best and are easiest to see, so we’ll be selecting one of the smaller 
cells from the Cell List Box.

V i e w i n g  i n  3 D

If you have exited MAX and do not still have TOP_CHIP loaded, you first 
need to load it.

 Step 1  Got to File > Import File.

 Select Load GDS File using current mmi25 max technology file.

 Click on Find... and select TOP_CHIP.gds, then click on Done.

First we’ll put the cells in alphabetical order to make it easier to find cells

 Step 2  Hold down the title bar at the top of the Cell List Box (in the illustration 
below, it says “/home/text/mmi_private/tutorial/max/Samples”) and 
select Alphabetize from the menu options.

 Step 3  Click on MMI_SRAM_wl_buf2_128x2.max with the RIGHT (Button-3) mouse 
button. It’s the first MMI_SRAM_wl... shown highlighted in Figure 63 below.

You should see this cell (notice that the cell name is displayed along 
the top).

 Step 4  If you can’t see the internals of the cells, type the hotkey i (View Internals).
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 Figure 63: MMI_SRAM_wl_buf2_128x2.max 

 Step 5  Now, from the View menu click on Display 3D View, or use the hotkey Alt-z. 
The cell display immediately changes to a standard orthogonal 3-D view, 
shown in Figure 64.

 From here, you will be able to rotate and zoom in/out of the view using 
the mouse buttons. The button functions are described in the MAX 
Message Area.
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 Figure 64: 3-D View of MMI_SRAM_wl_buf2_128x2

 Step 6  Rotate the view using Button-1. Press and hold down Button-1 and drag 
around the window to see the view rotate, as demonstrated in Figure 65.

 Figure 65: Rotated 3-D View of the Cell
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 Zoom into or out of the view using the scroll-wheel or zoom keys.

 Figure 66: Zoomed In on 3-D View

 Pressing the hotkey v will re-center the view in the window

 As MAX supports true transparency, layers underneath show slightly 
through the ones on top. Transparency values can be set in the Display 
Options section of the User Preferences menu.

TIP:
NOTE: Editing is not possible during the 3-D viewing mode. 
You must revert to 2-D to continue editing your cells.

RETURN TO

STANDARD

VIEW
 Clicking Button-3 will restore the original layout view (2-D).

 Remember that the Message Area displays the mouse button functions 
available during 3-D View.
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By now you should have a good grasp of MAX’s potential. In the next 
section, we will start creating layout.

I f  y o u  h a v e  p u r c h a s e d  M A X - L S  L a y o u t  S y s t e m  j u m p  n o w  t o  t h e  “ M A X - L S ”  
t u t o r i a l .

W h e n  y o u  h a v e  c o m p l e t e d  t h e  M A X - L S  s e c t i o n  r e t u r n  t o  P a r t  3  o f  t h i s  t u t o r i a l .

O t h e r w i s e ,  c o n t i n u e  o n  t o  P a r t  3 .
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PARTSIMPLE LAYOUT

OK, let’s get started on some layout. If you have MAX-LS and have just 
completed the MAX-LS tutorial, some of that information will be repeated in 
this part of the MAX tutorial.

For this section, we will be using the mmi18 technology.

 Step 1  If you still have MAX running, exit MAX (ctrl-d). Start MAX again with the 
command:

max -tech mmi18

 Step 2  To find out what technology you are using, go to the Help menu and select 
About Max... It should say that the technology is mmi18.

 Step 3  Go to the File menu and select New... This will bring up the File Select box.

 Step 4  Type in the cell name foo where it says Filename:. Then click OK, or hit Return.

The UNNAMED at the top of yor MAX window should now say foo. This 
means that you are now editing the cell foo. When you save it out it will 
be saved as foo.max.

The top of your MAX window also has the path to your cell foo.max. In 
this example the path is: 
“/home/text/mmi_private/tutorial/max/foo.max.”

Also, notice that foo now appears in the Cell List Box on the right side of 
the MAX window. The ‘B’ to the left of foo means that this cell only 
exists in memory (Buffer) and has never been saved.

 Other letters you will find to the left of cell names are:
“G” shows it is a Gcell (explained later) or Generator cell;
“M” indicating the cell has been Modified; and
“W” meaning the cell has been Written, or saved.
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Us i n g G c e l l s

While MAX can do very low level full custom layout, it also has a complete 
Tcl/Tk interpreter built in. Tcl is a language developed by John K 
Ousterhout at UC Berkeley. Tk is the windowing tool kit. Books on both 
are easily available. The Tcl/Tk interface in MAX allows full access to 
MAX lsyout functionality, providing unprecedented power and flexibility.

A gcell is a cell generator written in the Tcl/Tk language. The gcell 
generates layout for a cell automatically from “properties” that you specify 
using a simple menu interface. MAX comes with gcells to generate FETs, 
Vias, Text, and a poly_resistor.

CGELL

PROPERTIES

 Step 1  Go to the List Box along the right side and select fet from the list by 
clicking on it with Button-1. The G next to the fet indicates that this cell is a 
gcell, or generator.

 When you click the left mouse button (Button-1) on fet in the List Box, the 
fet generator window will pop up. It should look something like Figure 67.

TIP:
If you do not see fet in the List Box, click and hold Button-
1 over the List Box header to display the directory list, then 
select the directory ending in cells. This is the direcotry 
containing the fet and via gcells provided with the Micro 
Magic, Inc. software.
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 Figure 67: FET Gcell

 Step 2  Now, change the width to 2.0. This will make the nfet 2.0 μm wide.

 Step 3  Since we eventually want to use this device to make a 2 input NAND 
gate, change fingers to 2, and contacts to both.

Contacts allows you to put contacts on the left side, the right side, 
both sides, between the devices (all), or no contacts at all.

(Click on Help or refer to the Micro Magic, Inc. MAX User Guide for 
more details.)

If you click the left mouse button (Button-1) on the word both it will 
change to the next option. Clicking Button-1 on the little bar to the 
right of this option will bring up all the possible variations.

 Step 4  Now click Done.

Two nfets merged (stacked) together should appear, with the cursor 
attached to the lower left corner.

 Step 5  Click Button-1 to place the nfets in the window.
  PART 3: Simple Layout Tutorial MAX  Layout Environment Ver. 5.7 85



S IM P L E  L A Y O U TPA R T  3

86
 Step 6  Type v (the hotkey for Zoom To Fit Edit Cell under the View menu) and the 
layout will center in the window.

Your screen should now look like Figure 68.

 Figure 68: Generated nfet Gcell

The white text on the cell informs you that you are editing an nfet, and 
that it is 2 gates x 2 microns wide, at a .18 micron channel length.

Notice that the letter M appears to the left of foo in the Cell List Box. This 
tells you that foo has been Modified.

 Step 7  Zoom out by typing Shift-z or using Zoom Out from the View menu; or use 
the scroll wheel on your mouse (if you have one). You can also use the 
Zoom Bar at the bottom of the window just below the scroll bars.
  PART 3: Simple Layout Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7



S I MP L E  L A Y O U T
TIP:
You can undo whatever you ahve just done in MAX. Use 
the u hotkey or select Undo from the Edit menu. You can 
also Redo what you have just undone using Shift-u. There 
are 99 levels of undo in MAX. If you can remember back 
more than 99 items please call us, we would love to meet 
you!

S e l e c t i n g a n d  Mo v i n g L a y o u t

There are two types of layout you can select and move in MAX: objects 
and rectangles.

Objects may be sub-cells (cells), generated cells (gcells) or polygons.

Rectangles are basically flat layout.

TIP:
Be aware that rectangles may sometimes be refered to as 
paint in the MAX documentation. To create a rectangle, 
you draw out a box and fill it with “paint” of a certain 
layer.

There are many methods for selecting objects and rectangles.

 When MAX is in main mode (the default mode), if you simply drag 
out a region while holding down Button-1, whatever is within that box 
will be selected when you release the button, and will be highlighted 
in white.

For rectangles, only the portion of the rectangle that is enclosed by 
the box is selected.

For objects (cells, gcells, or polygons) if any portion of the object is 
enclosed by the box, that object is selected.
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SELECTING

LAYOUT

 Step 1  Drag a box over the stacked nfets we just drew. When you release the 
mouse button whatever is “selected”, in this case the fet gcell, will be 
highlighted.

MANIPULATING

LAYOUT

Once you have selected an object or rectangle, you can do lots of things 
with it.

 Step 2  For example, you can rotate clockwise by typing the r hotkey.
The R (shift-r) hotkey will rotate counter-clockwise. Try it.

 Type r three more times to rotate the object back to its original position.

 Step 3  You can move layout up/down/left/right one grid at a time by using the 
arrow keys.

 Step 4  You can also move any layout by first selecting it, then clicking and 
holding down the right mouse button (Button-3) and dragging it around the 
screen.

MAX also supports Cut, Copy and Paste in the same format you would see 
on any good Mac- or PC-based drawing program.

TIP:
All of the zoom, move, cut and paste, rotate, etc. 
commands specified with hotkeys also have menu 
equivalents. These can be found in the Edit, View, and 
Select menus.

Du p l i c at i n g  Gc e l l s

We now wish to create a couple of pfets. We could go back to the List Box 
and select the generator again, but there is another way.
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SELECT AND

DUPLICATE

GCELL

 Step 1  Simply select your nfet by either clicking over it with Button-1, or by 
dragging a selecting box around it with Button-1.

 Step 2  Now select Duplicate from the Edit menu, or type d. This creates a 
duplicate of the selected objects (or rectangles), slightly offset from the 
original.

 Step 3  Hold down Button-3 and move the new nfet above the existing nfet.

 If you hold down the Shift key with Button-3, the move will align to the 
existing fet as you move horizontally or vertically.

Notice that when you selected the fet and held down Button-3, the cursor 
changed to a hand. This change in the cursor tells you that you are in a 
mode other than main mode. In this case you are in move mode. 
Remember to look up at the Message Area to see what the functions of the 
mouse buttons are in your current mode.

EDIT GCELL

PROPERTIES

Now you will begin to see the true power of gcells.

 Step 4  Select the top nfets and then type e, or select Push Into Cell from the View 
menu. The pop-up menu shown in Figure 69 appears.
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 Figure 69: Edit Properties Form for fet Gcell

 Step 5  Click on pfet the change the selected nfet to a pfet.

 Change the width to 4, to make the pfet 4 μm wide.

 Change contacts to all by either clicking several times on the box next to 
the word contacts, or hold down Button-1 on the little bar on the right side 
of the box next to contacts and then select “all”.

 Step 6  Once you are finished, click Button-1 on Done to invoke the generator. This 
will change the old nfets to magically become new 4 μm wide pfets with 
contacts in the middle and on both sides. Zoom to fit (hotkey: v) and you 
should now see something similar to Figure 70.
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 Figure 70: Two fets Generated

S t r e t c h i n g  G c e l l s

As you have seen, gcells can be used to create fets and vias. The wiring 
tool can also automatically drop gcell vias. You can change the size of a 
gcell fet by:

 Using the e hotkey, and accessing the Edit Properties box, or

 Doing a Stretch Selected from the Edit menu (hotkey: Ctrl-Button-3).

STRETCH PFET Try this on your pfet.

 Step 1  Select the pfet by clicking on it with Button-1

 Move the mouse near the top border of the pfet.

 Step 2  Hold down Ctrl-Button-3 (the cursor will change into a double-headed 
‘stretch arrow’) and drag the mouse up. Release the mouse button.

Notice that as you stretch the pfet, additional contacts are added 
automatically.
  PART 3: Simple Layout Tutorial MAX  Layout Environment Ver. 5.7 91



S IM P L E  L A Y O U TPA R T  3

92
 To return to the original width, you can Undo the new width with the u 
hotkey or edit it again and change the width back to 4.

You can stretch via gcells in the same way, except the outcome is 
placing multiple vias.

TIP:
You can stretch a well contact to help you with things like 
quickly building guard rings.

A l i g n i n g O bj e c t s

It would be nice if our new fets were lined up. One way to align objects is 
to draw a ruler (hotkey: Ctrl-r), zoom way in, and carefully move the objects 
until they are aligned with the ruler. But a much easier way is to use the 
Align Objects command.

 Step 1  If you aligned the two fets when you duplicated the nfet, move one of 
them with Button-3.

SELECT

OBJECTS TO

ALIGN

First, select all the objects to be aligned.

 One easy way to select multiple objects is to hold down the shift key while 
clicking on them with Button-1 (Shift-Button-1)

 Using Shift-Button-1 adds something under the mouse to the selection.

 Alt-Button-1 subtracts what’s under the mouse from the selection.

You can tell when the gcell is selected because its outline is highlighted, 
and its name and size are also displayed in white. If there are multiple 
objects under the cursor, use the Selection Probe (demonstrated earlier in 
this tutorial) to select exaclty what you want.

 Step 2  Click with Shift-Button-1 over the two gcells until they are both selected.

Now you will use “the Box” to tell MAX how the gcells should be aligned. 
By selecting the gcells using Shift-Button-1, the “Box” has automatically 
been placed over the last gcell you selected.
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 The gcells will be moved so they align with the Box: in this case, it 
means the first gcell you selected will be moved so it aligns with 
the second gcell selected.

 You could instead draw the Box somewhere else (box mode, 
hotkey: b) and have all of the objects aligned to the Box (as shown 
in Figure 71.)

ALIGN THE

OBJECTS

Finally, use the Align Objects command.

 Step 3  Choose Align Objects from the Edit menu (hotkey: Ctrl-a).

 Make sure that left sides (the default) is selected (red dot showing).

 Step 4  Click Done. The gcells are now aligned vertically on their left sides.

Figure 71 shows both fets being aligned to the Box, which in this case 
was drawn separately (hotkey: b).

 Figure 71: Aligning fets Using The Box: a) Drawing the Box; b) 
Aligning “Left”
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C o n t i nu o u s  D R C

We are now going to see a really powerful feature in MAX, real-time DRC.

 Step 1  With the new pfets on top of the nfets, select the pfets.

 You can move the fet using the arrow keys (best for precise placement) or 
by holding down the Shift key and Button-3.

 Using the Shift along with Button-3 locks the move in the vertical or 
horizontal direction.

 Step 2  Use the arrow keys to move the pfet just above the nfet, as shown in 
Figure 72.

 Figure 72: Real-time DRC

 If you move the pfet too close to the nfet, little white dots appear. These 
little white dots tell you there is a Design Rule Check error (DRC error.)

 Notice that as you move the pfet closer or further away the DRC errors 
show up in “real” time! This is one of the power features in MAX.
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The Continuous DRC means you don’t even have to learn the DRC rules, 
or count grids. Just move things closer together until you see the white 
dots, and then back off a little. The small DRC error box, to the left of the 
zoom bar at the bottom of the MAX window, displays the number of 
errors.

VIEWING DRC

ON LAYOUT

If you are curious about what the DRC error is, you may view the results 
on the layout.

 Step 3  Drag a box around the white dots and type Shift-y or choose Explain DRC 
Under Box from the Misc menu.

TIP:
Remember that if you drag out a box using just Button-1, 
the box is drawn and everything underneath it is selected.

To draw a box only, type the Make/move box hotkey b 
and then drag out with box with Button-1.

 If the box is over only one DRC error, that DRC error will be 
displayed in the Message Area.

 If more than one DRC error lies under the box, the number of DRC 
errors is listed in the Message Area, and the list of all DRC errors 
under the box is displayed in the MAX command window (the shell 
window from which you started MAX).

VIEWING DRC

RESULTS ON

FORM

Another method of viewing DRC errors is to use the DRC Results form.

 Step 4  Move the pfet close to the nfet, as shown in Figure 73, so that DRC errors 
occur.
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 Figure 73: DRC Results Pop-up Window

 Step 5  Click on Next Error to step through all of the DRC errors. Notice that each 
DRC error is highlighted in the layout, and the text of that DRC error is 
displayed in the DRC Feedback window as well as the MAX Message Area.

 When you are finished looking at the DRC errors, click on Close in the DRC 
Feedback pop-up.

Refer to the MAX User Guide for more details on the DRC Results pop-up 
window. This window can also be used to view results of DRC runs with 
other tools, such as Mentor Graphics’ Calibre.

 Step 6  Move the pfet above the left nfet so that the gates of the pfet and left 
nfet line up (this should already be the case after you aligned them 
earlier).

 Then move the pfet up (arrow keys) until it is DRC correct as shown in 
Figure 74.

 to get it DRC correct, move up until there are no white dots showing, and 
the DRC status box on the lower left of the MAX window says drc clean. 
Sometimes there can be DRC errors even if you can’t see any white dots, 
expecially if you are zoomed out.
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TIP:
If the DRC status box says there are still DRC errors, but you 
cannot see any white dots, you can use the DRC Find 
Next Error command in the Misc menu or type the 
hotkey Shift-n. MAX will soom to the DRC error and 
describe the error in the MAX Message Area.

 Figure 74: FETs Lined Up

The Continuous DRC feature used design rules defined in the MAX 
Technology file. This single plain text file defines all the design rules 
needed by MAX’s extensive DRC. The technology file uses a simple table 
format for most rules, resulting in a compact, easy to understand file 
format that can be as short as a single page.

Micro Magic, Inc. provides common CMOS technology files as a starting 
point to build your own. In addition, you can build a prototype technology 
file automatically from an existing GDS file by choosing Import File from 
the File menu.
  PART 3: Simple Layout Tutorial MAX  Layout Environment Ver. 5.7 97



S IM P L E  L A Y O U TPA R T  3

98
IMPORT PDKS Technology information from a PDK, generally provided by the foundry, 
can be converted to MAX format using cds_convert. This will be covered 
further in Part 5 of this tutorial.

IMPORT

OPENACCESS

Technology information from a PDF for the process may also be imported 
using an OpenAccess database. We will address OpenAccess further in 
Part 5.

Wi r i n g Mo d e

Now you will route up the poly. You could route the poly by drawing 
rectangles and then filling them with poly (red) paint, but that’s a lot of 
work. There’s a much easier way — MAX’s built-in wiring tool.

WIRE TOOL

 Step 1  To use the Wiring Tool, type w or select add wire from the Edit menu.

Notice the cursor has changed. Remember, that’s to let you know 
you are in a different mode. In this case, you are in wire mode.

 Step 2  Place the cursor over the poly gate of the right hand nfet (fet on the 
bottom) and click Button-1.

 Now move the cursor up. A poly wire should follow the cursor, as shown in 
Figure 75.

If the wire doesn’t start in poly, check to make sure the Active layer is set 
to auto (in the upper left corner of the MAX window).
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TIP:
The wiring starts the wire in the active layer (very top of the 
palette). IF the Active layer is set to auto, the wire starts in 
whichever layer is under the cursor. If there are multiple 
layers under the cursor, it picks the highest layer. If you set 
Active to a specific layer (i.e. m1) then the wire will start in 
that layer no matter what is under the cursor.

 Figure 75: Drawing a Wire

 If at any time when in wire mode you wish to bail out and start 
over, you can do so by typing Ctrl-c.

ADDING

CORNERS IN

WIRES

As the pfet is not directly above the nfet we need a “kink” or corner in the 
wire. You do this by simply clicking with Button-1 at the place you want the 
kink.

 Step 3  Move the cursor up and then click with Button-1 to add a kink/corner. 
Notice that as you move the mouse, you also move the corner up and 
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down. When you click Button-1 again, the horizontal portion of the poly 
wire will lock in place.

 Now move the cursor to the right until it’s directly under the pfet poly and 
click Button-1 again to add another kink/corner.

 Finally, move the mouse up until it’s over the right pfet poly gate. If you 
glance up to the MAX Info Bar, notice that it says “BUT-1 adds new 
segment BUT-3 ends”. This means that when you click Button-3 (right mouse 
button) it ends the wire.

 In fact, MAX does even better than that. If you click Button-3 over the poly 
but are not exactly in the middle of the wire, MAX will actually snap the 
wire into place for you and end it. How about that?

If you didn’t put the wire exactly where you wanted it don’t worry. You 
can always undo.

Your layout should now look like Figure 76.

 Figure 76: Drawing Poly Wire
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TIP:
If you want to back up one step in the wire, use the Undo 
hotkey u. You can undo (u) back to the beginning of the 
wire.

If you cant to cancel the current wire, use Ctrl-c. Ctrl-c 
always aborts any sub-mode and returns you to main 
mode.

You might have noticed that the little piece of poly you just added is a 
brighter color than the poly that was part of the gcell fets. This is a feature 
in MAX designed to help you know what you are editing. Rectangles or 
objects drawn in the cell you are currently editing show up brighter than 
the cells you are not editing. This includes gcells. Therefore, since you are 
not editing the gcell fets, they show dimmer than the cell you are editing.

 If you wish to have all of thelayers show up with the same brightness (even 
in the gcells or subcells) then go to File > User Preferences, select Display 
Options..., then select Dim Non-Edit Cells and click Done. The radio button 
should go “off” with the non-edit cells no longer dimmed.

E d i t i n g  a  P l a c e d  W i r e

Once a wire has been placed, you can edit that wire. The Edit menu 
contains commands to Move, Stretch, and Fill any rectangles, including 
wires. There is also the Edit Wrie command as we saw earlier in this 
tutorial.

You many find that it is sometimes even faster to simply redo a wire if you 
need to make a number of edits.

 If you just want to move the wire a little you can select the wire segment 
you wish to move and then nudge it using the arrow keys. The arrow keys 
will do a “stretchy” move.

 If your segment has a via at either end you need to use the Edit 
Wire command.

STRETCHING

WIRES

Let’s try a stretchy move with our connected fets.
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 Step 1  Draw a box by holding down and dragging Button-1 so that it encloses 
port of all of the pfet, and part of the vertical section fo the poly wire as 
shown in Figure 77.

 Figure 77: Stretch Move

 Step 2  Press the up arrow key a few times and notice that the poly wire stays 
connected.

 Step 3  Undo your stretchy move with the u hotkey.

MOVING A

WIRE

Now let’s move the middle segment of the poly wire.

 Step 4  Select the horizontal section of the poly wire by clicking on it with Button-1, 
as shown in Figure 78. You may need to click multiple times to select the 
entire horizontal section of the wire.
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 Figure 78: Moving Wire Segment

 Use the up and down arrow keys to move the segment. Notice that the wire 
stays connected.

TIP:
If you want to move (and keep the net connected) the 
segment a long distance, you can use Ctrl-Button-3. Using 
Button-3 without Ctrl will move the segment but will not 
maintain connectivity.

If you are using the arrow keys for the move and do NOT 
want the wires to stretch, hold down the Shift key when 
moving the selected layout.

 Finish wiring up the fets gates by drawing the second poly wire as shown 
in Figure 79 using the wire (hotkey: w) command.

Now wire up the metal just as you did the poly.
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 Enter wire mode (hotkey: w) and then click on one of the contacts and 
draw the metal so it looks like Figure 79. First wire the two left contact 
regions and then add the connection to the right pfet contacts.

 Figure 79: Wired 2 Left Poly Gates

When starting a new wire, the Active Layer box (remember it’s on the top 
left just under the File menu) tells you in which layer the wire (or circle or 
polygon) is going to be drawn. If it is set to auto it picks the layer under 
the mouse.

If you want to tell it exactly which layer to start drawing on, then hold 
down Button-1 over the Active Layer box. When the pop-up appears simply 
place the mouse over the layer you want and then release the button. All 
wires will now start in this layer.
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TIP:
To change the layer of the wire while you are in wire 
mode (before you start drawing the wire or before you 
drop a via), type the hotkey: l (“ell” - lower case L).

If you type the hotkey m while in wire mode (w), the Wire 
menu will appear. The Wire menu changes based on 
whether or not you have already started the wire.

Also, remember that if you type the Space hotkey, the list 
of hotkeys active in the current mode will appear.

SAVE EDITS Since you have done a fair amount of work you should now save your 
layout.

 Step 5  Type Ctrl-s or select Save from the File menu.

Notice that the M next to the foo in the Cell List went away. There is 
now a W next to foo, meaning that this cell has been written.

A dd i n g  t h e  P o we r  R a i l s

We are ready to put in the power rails. Let’s say we were layout out this 
NAND gate for a standard cell library. Furthermore, assume that the 
power and ground rails are run in metal 1 (m1) and that they are 2μm 
wide.

Before adding the power rails, you need some more information about the 
wire mode, the box and the palette.

We could use the wire tool to draw the power rails, by drawing wires with 
width set to 2μm.

 To do this, you would start drawing a normal wire (hotkey: w) in layer M1, 
positioned above or below the fets.

 Then, press and hold Button-2 to access a pop-up menu for wiring options 
including the current wire width. Here you can set the wire width of the 
current wire segment(s) to 2μm, or the width desired.
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 You can also set the default width, spacing and snap grid for each wire 
layer in the Wiring Parameters menu. It is found under File > User 
Preferences, then choose Wire Setup... (or just use the Shift-w hotkey) then 
choose Wiring Parameters.

However, this is a good opportunity to use rectangles directly. MAX has 
excellent capabilities for low-level layout -”rectangle hacking”, and this is 
an ideal way to put in the power rails. To use rectangles effectively in MAX 
we will first have to learn to manipulate the Box and the Palette.

Th e  Bo x

The Box is important in MAX because it is used by many commands to 
determine where you are going to place, or do, something. For painting 
(creating rectangles of a specific layer) the Box marks the region where 
paint is going to be drawn or erased. We have already seen the Box on the 
screen while doing the commands above; for example, the Align Objects 
command.

 You can create a Box by simply holding down Button-1 and dragging the 
outline around a region.

TIP:
Drawing a Box by holding down Button-1 also 
automatically selects what is under the Box, so don’t drag 
a box around an entire chip! Use Box Mode (below) for 
that.

Assuming you were in Main Mode (the default), any paint within the Box is 
selected. This is the way we have done things thus far.

 You can also position the Box exactly by typing Shift-b or selecting Box 
Dimensions from the Misc menu, or by clicking on the Box Size window in 
the lower right corner of the display. Any of these will open a menu that 
allows you to precisely set the Box size.
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B o x  M o d e

Box Mode is useful when you need to do detailed layout. You can resize 
the box to the exact size you want, and place it exactly where you want it, 
without having to worry about corrupting any existing layout that you 
might have inadvertently selected.

TIP:
Dragging out a box in Box Mode does NOT select 
anything!

After typing b (or Make Box in the Misc menu) you can do any of the 
following:

 You can specify a new box position by holding down Button-1 as you 
drag out a region, then releasing Button-1. The cursor shows as a 
hand with a pointing finger.

 Resize the existing box by moving the mouse over the sides or corners 
of the existing box until the cursor icon changes (to either a ‘stretch-
arrow’ or a ‘corner’), then drag that side or corner using Button-1.

 Move the box by holding down Button-3 and moving the mouse (a 
hand cursor)

Remember, the above commands function while you are in Box Mode. You 
can always look at the MAX Message Area (to the right of the menus) to 
determine your current working mode.

T h e  P a l e t t e

A few more words about the Smart Palette (along the left side of the MAX 
window).

The Smart Palette provides many features. It allows you to control what 
you can see, what you can select, what’s under the cursor, what can be 
drawn as rectangles, and what the layers look like.
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 Remember, the MAX Message Area will tell you what the available 
options are if you place the mouse over the palette.

Here’s a reminder of how to use the palette:

 To control which layers are visible, click Button-1 over the little 
colored square (to the left of the layer labels -m5 ... v45 ... m4, etc.)

 To control visibility by group, click Button-1 on the group button: 
metal, active or other. This is a very useful feature for reducing 
clutter when you are working on a subset of layers.

 To control which layers are selectable, click Button-1 on the layer 
name (such as m2, v12, pfet, and so on). The layer name button will 
turn grey, and that layer will be disabled (NOT selectable).

Or, click Button-3 over the group button to toggle selectability for 
that entire group.

 Layers which are under the mouse are indicated by a small 
rectangular red LED just to the left of the colored boxes.

 Layers which are currently selected are indicated by the layer 
name(s) changing from black to red.

 Finally, you can change the color or stipple patterns of any of the 
layers by clicking Button-2 (middle mouse button) over either the 
colored box or the layername. This brigns up the MAX Color/Stipple 
Editor. Using the editor, you can even change the colors of things 
like the background (for example, make it black), the grid, labels, 
etc.

While the grid color is changed in the MAX Color/Stipple Editor, the 
grid size and style are changed in Grid Setup... from the File>User 
Preferences menu, or by typing Shift-g hotkey.

P a i n t i n g t h e  P o w e r  R a i l s

Now we are ready to add the power rails as paint rectangles.

 Step 1  Type the Add Box hotkey, b.

 Step 2  Hold down Button-1 and drag out a region where you want to paint the 
new Vdd power rail, as shown in FIG.
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 Figure 80: Drawing a Box for Painting Power Rails

 Step 3  Place the cursor over the M1 button in the palette (either over the name 
m1 or the bright blue square to the left of the name), then click the paint 
hotkey p.

TIP:
You can also type the p hotkey over any piece of m1 in 
the layout. Be sure there are no other layers under or over 
m1. MAX will fill the box with all of thelayers under the 
cursor.

If you click the p hotkey over a place with NO 
layout, then the layout of all layers in the area 
under the box will be erased.

RESIZING

RECTANGLE

If the box isn’t the size you want (see the lower right corner of the window 
for the box size) you can make the box exactly 2μm tall or you can edit the 
rectangle. Notice in the figure above that the size of the box is 3.65 x 
1.355.
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 Step 4  Undo (u) the m1 paint before we resize the box.

 Step 5  To make the box an exact size type Shift-b or select Box Dimensions from 
the Misc menu. A pop-up menu appears (see Figure 81).

 Figure 81: Box Dimensions Pop-up Form

 Make sure the Specify Box By: is set to origin + size. Then type in 4.0 for the 
width and 2.0 for the height. Click Done.

 Step 6  Fill the box with m1 again by clicking p (paint) on ‘m1’ in the palette or on 
any m1 in the layout.

STRETCHING

RECTANGLE

You can change the size of a rectangle by stretching an edge using the Edit 
Edge command (hotkey: a) found in the Edit menu.

 Step 7  Type the a hotkey. The cursor changes to let you know you are in Edit Edge 
mode.

 Move the cursor (pointing finger) over the right edge/side of the m1 
rectangle that we just drew. A select line will show you which edge you 
are editing, as shown in Figure 82.
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 Figure 82: Editing Edge of Power Rail Rectangle

 Step 8  Hold down Button-1 and move the mouse to the right to stretch the edge. 
Release the button when the edge is where you want it.

EDIT

PROPERTIES OF

RECTANGLE

You can also change the size of a paint rectangle by first selecting it, 
andthen selecting Edit Properties from the Edit menu (hotkey: Ctrl-p).

 Step 9  Let’s change the width of the rectanble back to 4 by editing it’s 
properties. Select the m1 rectangle by clicking on it with Button-1 and type 
Ctrl-p.

You should now see a pop-up like Figure 83.
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 Figure 83: Edit Rectangle Properties pop-up

 Change the width back to 4 and click Done.

PAINT EDIT

MODE

One other way you can edit paint rectangles is to use the Paint Edit Mode.

 Step 10  Select the power rail again, and type the e hotkey. (View menu> Push into 
Cell. MAX is smart enough to know that because a paint rectangle has 
been selected it should go into Paint Edit Mode.)

You will now see the paint rectangle outlined with dots at the 4 corners 
and in the middle of each edge, as shown here in Figure 84.

 Figure 84: Paint Edit Mode for m1 Rectangle
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As always, the MAX Message Area tells you what mode you are in and the 
function of each mouse button while in that mode.

 Holding down Button-1 in the middle of the rectangle moves the 
rectangle.

 Clicking-and-dragging with Button-1 on one of the dots resizes the 
rectangle.

 Button-3 exits out of Paint Edit Mode.

 Try resizing and moving the rectangle. Click Button-3 to exit Paint Edit 
Mode. Type the undo command (hotkey: u) to move the power rail back 
to it’s original position and correct size.

DUPLICATING

RECTANGLE

Once you have painted the top power rail you can simply duplicate it and 
move it down for the bottom rail.

 Step 11  Select the power rail with Button-1.

 Step 12  Duplicate the top power rail (hotkey: d) and move it down using Shift-
Button-3, as shown in Figure 85.

TIP:
If you duplicate something and hold the Shift key down 
while moving it, the duplicated item will stay lined up with 
the original.
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 Figure 85: Power Rails Placed

 Step 13  You can move both of the power rails as close as possible to the fets, as 
shown in Figure 85 (above) by selecting each power rail and using the up 
and down arrow keys while watching the DRC Status Box to make sure 
there are no DRC errors.

WIRING UP

RECTANGLES

Now that you have painted in your power and ground rails you want to 
wire them up using the Wiring Mode as before.

 Step 14  After you have entered the Wire Mode (w), hold downthe Shift key and 
click Button-1 (Shift-Button-1) over the middle of the pfet contact region. 
This will start an m1 wire using the width of the m1 underneath the cursor.

 Click with Button-3 on the m1 power rail to terminate.

By holding down the Shift key you are telling the wire tool to use the 
width of the wire under the cursor and NOT the minimum wire 
width.

 Step 15  Now connect the right nfet contact region to the ground rail.

Your cell should now look like Figure 86.
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 Figure 86: NAND Wired to Power Rail

W i r i n g  M o d e  -  C h a n g i n g  L a y e r s

Notice that the inputs and outputs are all found within the power straps. 
What if they needed to be brought out so a router can get to them?

Let’s assume the router requires all signals to be at the top of the cell and 
in m1. You need to route the poly wires over the m1 power straps and 
then change to m1.

Wire Mode in MAX can make this job easier since it can change layers for 
you.

CHANGING

WIRE LAYER

 Step 1  To route the wire, type w (for Wire Mode) and click Button-1 over the upper 
end of one of the poly gates.

 Step 2  Drag the mouse up and over them1 power rail, drawing the poly wire.
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DROPPING A

CONTACT/VIA

 Step 3  Type d. This will drop a poly to m1 contact for you, which you can then 
move around.

 Now try moving the mouse to the left. This draws an m1 line left of the 
contact. While holding themouse to the left try moving it up and down.

Notice that the contact tracks the verticla location of the mouse as you 
move it. Also, notice that the DRC is working while you are moving the 
contact. Whenever you get too close to the Vdd line, the little white DRC 
dots appear, as you can see in Figure 87.

 Figure 87: Active DRC Showing Errors As Wire Is Drawn

 Step 4  Move the mouse around to get the contact where you want it (with no 
DRC errors showing) and type hotkey a to ‘freeze’ or anchor the contact in 
place. Remember, you may need to refer to the DRC Status Box to make 
sure there are no DRC errors. 

Then drag the mouse upward.
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TIP:
To access the commands in Wire Mode, press and hold 
Button-2. Next to each command is the hotkey for that 
command. Another way to find out the hotkeys while in 
Wire Mode is to press Space.

So, to freeze the via in place, you could also have 
selected anchor vertex from the Wire Mode pop-up.

As you continue dragging the mouse upward, notice that you are now in 
m1. If you type d (drop a contact) again, you will add a via1 and 
automatically change to layer m2. This will continue until your technology 
runs out of metal layers.

The generic technology file we have included (mmi18) has six layers of 
metal.

TIP:
You can zoom in on an area while in wire mode. Click 
hotkey z and zoom in on the desired area using Button-
1. You are then returned to wire mode. You can also 
zoom out (Shift-z) or zoom to fit (v) while in wire mode.

 Step 5  End the wire by clicking with Button-3 at the desired location, shown in Fig.

TIP:
Typing d in Wire Mode drops a contact and raises 
you to the next higher layer.

If you want to go down a layer simply type Shift-d and 
the wiring tool will drop a contact or via, and bring you 
down to the next lower level.

There are LOTS of other options in the wiring tool, such as snap to grid, 
wire in 45’s, change wire layer, and more.
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 To see the Wire Mode menu simply hold down Button-2 while in wire 
mode. This opens the Wire Mode pop-up menu.

 One of the Wire Mode options is Shift-w, which brings up a more 
extensive wire menu (also found as Wire Setup... in File > User 
Preferences.) This menu gives you such options as Active Layer (which 
can also be set via the Active Layer Box in the upper left corner of the 
MAX Window), the Default Layer, Snap options, and you can even 
override any or all of the wiring parameters.

TIP:
The same hotkey can be used for different functions in 
different modes.

For example, while in Wire Mode the Shift-w hotkey brings 
up the Wiring Menu. In the Main Mode the Shift-w 
hotkey does an Add Wire Bus.

Remember, for a list of all the options (hotkeys) available in wiring 
mode, hit the Space bar, or select Help > hotkeys.

The Space bar hotkey option works for ALL modes in MAX.

 Step 6  Wire up the other poly input.

Your cell should now look like Figure 88.
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 Figure 88: Inputs of NAND Brought Outside

ALIGNING

WIRES

If the top of the m1 wires are not aligned as shown in Figure 88, there are 
a number of ways to align them.

 Step 7  The easiest way is to draw a box and select the top edges of both wires, 
as shown in Figure 89.

Then click the delete hotkey q and the selected paint will be erased.

 If there are multiple layers selected and you only want to delete a single 
layer (m1) move the mouse over m1 in the palette or over a piece of m1 
in the layout and type the erase hotkey o.
  PART 3: Simple Layout Tutorial MAX  Layout Environment Ver. 5.7 119



S IM P L E  L A Y O U TPA R T  3

120
 Figure 89: Aligning Wire Ends

 You can also use the Fill command in the Edit menu to extend both top 
edges of the m1 wires up to the top edge of the box. (Refer to the Micro 
Magic, Inc. MAX User Guide for more details.)

C h an g i n g  L ay e r s

We are getting ready to finish this cell and your boss has just informed 
you that the power rails have been changed from m1 to m2. We’ll show 
you two ways of changing the power rails to m2.

1ST METHOD

OF CHANGING

LAYERS

You’ll see later that there is an easier way to change layers for this 
rectangle, but this method can be useful for other types of edits.

 Step 1  To change the first power rail, simply click Button-1 over the upper (Vdd) 
rail to select it. You may have to click Button-1 twice to get the entire 
rectangle. Notice that the Box encloses the last thing you selected.
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 Step 2  Now if you type the Erase command (hotkey: o) over blank space 
(background) on the screen it will erase everything within the box. But 
wait! You also have some poly within the box. If you erase everything 
inside the box your poly will also go away.

 Undo (u) your last change.

MAX allows you to selectively erase layers.

 Step 3  The power rail should still be selected. If not, select it again with Button-1.

 Step 4  Use the Erase command (hotkey: o) over a piece of m1 in the layout, or 
over ‘m1’ in the palette. The Erase command (o) tells MAX to erase those 
layer(s) under the cursor.

Once you have erased the m1 layer, notice that your Box is exactly 
the size it needs to be for the m2.

 Step 5  To repaint the erased m1 with m2, simply click the p hotkey (fill with paint) 
over ‘m2’ in the palette.

 Instead of using the Erase command, you could also have used the 
Delete or q hotkey to delete the selected item.

CAUTION:
Delete will delete everything you currently have selected, 
including paint, polygons, gcells, and sub-cells.

As a reminder, there are several options for mouse selection.

 Clicking Button-1 will select the object or rectangle of paint under the 
cursor.

 Holding down Shift with Button-1 will add to the selection.

 Holding down Button-1 while dragging out a region will select 
objects and paint within that region.

2ND METHOD

OF CHANGING

LAYERS

An easier way to change the layer of a rectangle is once you have selected 
the layer, use the niftly little Change Layer feature found in Edit Properties... 
under the Edit menu.

Let’s change the lower (GND) layer m1 and replace it with m2.
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 Step 1  To do this, simply select the m1 rectangle, then choose Edit > Edit 
Properties..., or type the Ctrl-p hotkey.

 Step 2  Change the layer to m2 and click Done. You should now have something 
similar to Figure 90.

 Figure 90: Edit Properties... Layer ‘m1’ Changed to ‘m2’

F i n i s h  W i r i n g  t h e  N A N D  G a t e

You now need to attach the power and ground lines to the new m2 straps.

To do this, use the Wire Mode.

 Step 1  Start the wire (w) from the m1 wires you drew earlier using Shift-Button-1, so 
that the wire width with match.

 Step 2  When you are over the m2 straps type d to add a via to m2.

 Step 3  Click Button-3 to end the wire.

 Repeat for the second power rail.
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You should now have something similar to Figure 91.

 Figure 91: Connected Power Rails

Next, we need to route the output of the top over the m2 next to the 
inputs so the router can get to it as well.

 Step 4  Start a wire (w) over the left pfet contact region (Button-1). Move the 
mouse up.

Notice that if you go straight up, you create DRC errors as shown in 
Figure 92.
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 Figure 92: Poly Gcells and M1 Wires Showing DRC Errors

 Step 5  So that there are no DRC errors, add two corners such that the m1 wire 
makes a job to the left, and end the wire.

Your design should now be DRC correct and look similar to Figure 93

 You’ve done a lot of work so save it by typing Ctrl-s.
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 Figure 93: NAND Gate Wired Up

There is one last thing before we are finished with our NAND gate.

The input and output nets of the NAND gate should be marked with 
unique names. This is accomplished by adding Text to the nets.

 To add Text, you first select the rectangle where you want to put the text. 
Simply click Button-1 over the rectangle, which will select the rectangle 
and place the Box around it, and Add Text (hotkey: t).

 To edit text that has been placed, first select the text (it will turn white) and 
press Shift-t to bring up the MAX Text Edit dialog box.

PLACE TEXT

 Step 1  Select the ground (lower) rail using Button-1.

 Type t for text, or choose Edit > Add Text. The MAX Text Edit dialog box will 
appear as shown in FIG.

 Enter the name GND into the Text field.
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The MAX Text Edit dialog box permits you to set the type of Text label: 
input, output, and so forth. Marking labels as inputs, outputs, global, 
etc. can be useful for use with other extraction or routing tools.

You can also specify the Text “position”, such as n for north or s for south. 
Specifying the orientation of the Text, relative to the crosshair that marks 
the Text location, places it on one side or another for easier viewing.

TIP:
North and south orient vertically, above or below the 
crosshair. All other directions orient horizontally, to the left 
(nw, w, sw) or right (ne, e, se) sides of the crosshair.

The Text “type” can be a point (the default) or a box. The”box” option 
produces text which marks a specified area, but is rarely used.

 Step 2  Specify the GND text direction to be e (east) and specify that it is a global 
signal.

 Step 3  Now move the mouse to the point on the layout you wish the text to be 
and click Button-1.

 Click on Done or hit Return.
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 Figure 94: Adding Text “GND” to Bottom Power Rail

In this tutorial:

 VDD and GND are marked as global, and are positioned east (e). The 
default location for the text point of origin is in the center of the 
selected rectangle. Text was positioned at the far right side of the 
rectangle.

 The inputs (In1, In2) and output (Out) were marked as local, and are 
positioned north (n).

 Step 4  Add labels for VDD, In1, In1, and Out as shown in Figure 95.
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 Figure 95: Adding Text Labels

 Remember to save your cell (Ctrl-s).

At this point our little NAND gate example should be done, and yours 
should look very similar to Figure 96.
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 Figure 96: Finished NAND Gate

COPY CELL TO

NEW NAME

You can copy the cell into a new name. Let’s call it my_nand.

 Step 5  Select Save As... from the File menu.

 Type in “my_nand” in the Filename field and click OK.

 You will now see both foo and my_nand in the List Box. You are currently 
editing my_nand.

S e l e c t i n g N e t s

MAX can trace connectivity through vias and contacts to interactively 
show everything connected to a net.

 Place the mouse over any piece of metal, poly or diffusion and type s, or 
choose Select > Select Net. MAX will automatically select the entire net 
that is connected to that piece of layout, and will also display thenet 
name, if known, in the MAX Message Area. The net name(s) are taken 
from any Text (labels) attached to the net.
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 Move the mouse over the m1 rectangle for ‘In2’ in the upper right corner.

 Type the s hotkey. You should now see the net highlighted as in Figure 97. 
Also, in the Message Area, you should see “Selected Net: In2”.

 Figure 97: Highlighted Net

If there are multiple layers under the mouse cursor, you type s multiple 
times to cycle through the nets.

TIP:
One nice feature often used for debugging is that when 
MAX selects a net the names of all of the text labels on 
that net are displayed in the MAX Message Area. For 
example, if you select VDD and the names VDD and GND 
both appear, you know you have a problem.
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A d d i t i o n a l  C o m m a n d s

Some of this is a repeat of earlier information. It’s here again simply as a 
reminder.

 The Cursor Probe command is another way to see which layers and 
objects are under a particular point.

 To Probe, put the mouse over some layout geometry in your cell 
and select the Cursor Probe hotkey l (“ell”, lower case L).

 You could also choose Select > Cursor Probe, then point at the 
location you want to probe. The Cursor Probe menu that appears 
contains a list of all the layers and objects under that point.

 To select a rectangle or other object, click on it in the pop-up with 
Button-1. To deselect it, click again.

 by default, only items in the current edit cell are displayed, since 
those are the only ones you can effectively manipulate. But if you 
choose the All Expanded Cells radio-button, the list will contain 
everything in any cell under the point where you probed.

 You can also clear the selection by choosing Select > Clear Selection.

 Another way of duplicating layout is to use the Copy Cell Buffer 
command in the File menu. This command will copy the current cell 
buffer to a new cell buffer in memory. The new cell will be saved to 
disk when you Save the cell.

 The Save As command (also in the File menu) is similar to Copy Cell 
Buffer, but also immediately saves the cell to disk.

 If you are working on a cell and want to discard its contents, perhaps 
to completely replace it with another cell, you can use the Delete Cell 
Buffer command (File menu) to delete the in-memory copy of a cell. 
This command does not affect the file on disk.
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PARTBIGGER DESIGNS AND 

HIERARCHY

Now let’s use our NAND gate and an inverter cell to build something a little 
bigger.

LAUNCH MAX

USING MMI18

 Step 1  If you have quit out of MAX, start it using 

max -tech mmi18

 Step 2  Go to the File menu and select New... Name the new cell “row”.

 You should now be editing row.max.

 Look up at the title bar. It should say: max: B row.

MAX does not automatically load all the cells in a library. Auto-loading 
all the cells can be done from the Cell List if all MAX cells in the 
directory use the same technology, or by adding it to your max.rc file.

Because the tutorial directory contains both cells in the mmi25 and mmi18 
technologies, we’ll load the cells manually.

 Step 3  Select File > Open, then INV.max, and click OK. Do the same for NAND2.max.

You should now see INV and NAND2 listed in the Cell List box.

 RIGHT-click (Button-3) on “row” in the Cell List to return to your new cell.

DROP A

NAND2

 Step 4  In the Cell List box, click on NAND2 with the LEFT mouse button (Button-1).
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This drops an instance of NAND2 into your row cell. Now you should see 
something like Figure 98.

You only see the instantiation of the NAND2 cell and not the internals. 
We’ll cover that later.

(Remember, clicking with the RIGHT mouse button (Button-3) loads that 
cell into MAX.)

 Figure 98: Instantiation of NAND2 Cell

 Step 5  Thie new cell should already be selected. If not, select it now by clicking 
with Button-1.

SET UP ARRAY

 Step 6  Select Array Cell... from the Edit menu.

 Enter 4 for the columns field and Duplicate Cell for the type.
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 Look at bbox layer. By default it says _bbox_ which is the rectangle 
containing all of the layout of the cell. For this cell the nw layer extends 
beyond the power rails, and we need to use the prb layer so that the wells 
overlap.

 Click on the rectangle to the right of _bbox_, scroll down and select prb.

The array cell pop-up should now look like Figure 99.

 Click on Done.

 Figure 99: Array Cell Pop-up

 Step 7  Zoom out (hotkey: Shift-z) so that you can see all of the NAND2 instances.

 Step 8  Return to the Cell List box and click on INV with Button-1.

 Place it to the right of the NAND2 cells as shown in Figure 100.
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 Figure 100: ‘INV’ placed to the right of ‘NAND2’ Cell

POSITION INV

CELL

We now need to move the INV so that it abuts the NAND2 gates.

 Step 9  The INV should still be selected. If not, click with Button-1.

 Step 10  Select one of the NAND2 gates by holding down the Shift key as you click 
with Button-1. You should now have the INV and one of the NAND2 cells 
selected.

 The align command aligns all cells to the last cell selected. Menu select 
Edit > Align Objects, or type Ctrl-a. When the pop-up opens, align the 
objects to the bottoms, then click Done.

 Step 11  Type the hotkey i to view the internals of all of the cells.

 Step 12  Select just the INV cell. We want to move it over so that the power rails 
abut. Hold down Shift-Button-3 (lock move either horizontal or vertical) and 
move INV over until the power rails abut as shown in Figure 101. It will be 
easier to abut the cells if you zoom in on either the upper or lower power 
rails.
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 You can also use the left arrow key to move the INV over one grid unit at a 
time.

 Figure 101: MAX Hierarchy - INV Abuts NAND2

While moving the inverter, white dots may appear indicating that the DRC 
check is working. DRC checking runs automatically as you go, and the 
dots disappear once the inverter is correctly positioned. The DRC status 
area in the lower left corner of the MAX window should say “drc clean”.

P u s h,  P o p ,  a n d E d i t  i n  P l a c e

Let’s look at editing hierarchical layout. At this point let’s say our boss 
comes over again and says:

“Sorry, but you need to bring the outputs to the bottom of the cells.”

There are two ways to do this. We will use one method on the INV cell and 
the other (just to be different) on the NAND2 cell.
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F i r s t  M e t h o d :  E d i t i n g  b y  P u s h i n g  I n t o  C e l l

EDIT BY

PUSHING IN

 Step 1  First, select the INV cell by moving the cursor over INV and then using f, or 
Select > Select Cell. If you get a fet or row selected, type the f hotkey 
multiple times until INV is selected.

 Step 2  Now type e to edit the cell, or menu select View > Push into Cell.

Now that you’re inside the cell, use the wire mode to:

 Step 3  start the wire (w) at the right nfet contact region, and click Button-1 while 
moving the mouse down,

 drop (d) a contact to m2,

 anchor (a) the via, move the mouse downward past the GND power rail 

and

 end the wire using Button-3. Refer to Figure 102.
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 Figure 102: Editing ‘INV’ Cell - Wiring Output

 Step 4  Now type Ctrl-e or menu select View > Pop out of Cell to “pop” up a level 
and return back to row.max.

You should now see that the change you made in the INV cell within 
row.max.

S e c o n d  M e t h o d :  E d i t i n g  C e l l  o r  O b j e c t  i n  P l a c e

EDIT IN PLACE Now let’s edit the NAND2 cell. To do this one we are going to use the Edit 
Cellor Object in Place option from the View menu.

 Step 5  Select one of the NAND2 cells, then type Shift-e to Edit in Place.

Notice that the NAND2 cell you selected appears darker than the other 
cells. This indicates that you are now editing that cell.

 Step 6  Go ahead and add your new wire just as you did for the INV cell. You will 
need to put the m1 to m2 via directly over the nfet contact region.
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 Observe that the wire appears in ALL INSTANCES of NAND2, not just the one 
your are editing. Look down at the DRC status in the lower left corner 
ofthe MAX window and it should say drc clean.

 Step 7  Type Ctrl-e to pop back up to the top level (row).

 Your row cell should now look like Figure 103.

 Figure 103: Outputs Brought Out to Bottom

Now, just for grins, let’s wire up two of the gates.

 Since we want to wire them up in row.max and NOT in NAND2.max, we 
must first make sure row.max is our edit cell.

NOTE: You can always tell which cell you are editing by looking at 
the description in the MAX Title Bar.

To get back to row.max (if you’re not there already) there are different 
methods:
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 Step 8  Type Ctrl-e a few times or until you are sure you have popped out of any 
cells you entered when using Shift-e or View > Edit Cell or Object in Place. 
Watch the MAX Title Bar.

 You can also click with Button-3 on row from the Cell List box.

In general, push, pop, and edit in place work well for cells in the same 
hierarchy, while using the Cell List boxes is the preferred method for 
traversing larger, less connected databases.

 Step 9  Now that row.max is your edit cell, use the wire mode to hook up a couple 
of wires. 

 Notice that these wires are once again darker than the wires in the cells.

 Figure 104 shows a zoomed in view of a couple of gates wired up within 
row.max. You can see that the new wires in row.max (the current edit cell) 
are darker than the wires contained within NAND2.max and INV.max.

 Figure 104: Cells Wired Up

Let’s save our work.
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 Step 10  Menu select File > Save Multiple, then Save Edit Cell and Descendents. This 
saves the current edit cell row, as well as any modified cells that are 
instantiated in that row.

 Step 11  Exit out of MAX by typing Ctrl-d or selecting File > Exit.

 If you have made changes to cells since your last save, you’ll get a 
warning pop-up message. You can either Exit and Lose Changes or Cancel 
and save the cells.
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PARTIMPORTING GDSII AND 

CUSTOMIZING MAX

R E A D I N G  I N  G D S I I  F I L E S  A N D  M A X  T E C H N O L O G Y  F I L E S

Each GDSII or MAX layout file needs an associated technology file to 
describe the layer names, how layers connect to each other, and layer colors 
and fill patterns. This tech file contains the color (HSV or RGB), the 
transparency, and the dot/stipple pattern and/or outline settings, DRC 
rules and other information concerning each layer. It also contains 
information on how to map GDSII layer numbers to layer names.

The technology file we used for TOP_CHIP near the beginning of this tutorial 
is a generic technology created using Micro Magic, Inc. standard layer 
definitions and colors. When you read in your own GDSII file, MAX will need 
the information for that technology. We will cover two different ways for 
obtaining that information.

C r e a t i n g Te c hn o l o gy  F i l e s  f r o m G D SI I  F i l e s  

One way to get the technology information is to let MAX figure out what the 
layers are. You’ll need to have a list showing you which GDSII layer 
numbers map to which layer names. This is used to verify that MAX picked 
the layers correctly. MAX generally figures out metal, via, and poly layers 
correctly for digital CMOS processes.

MAX will default to the Micro Magic layer color and fill patterns. You can 
modify these settings as needed, and as often as needed. Black background 
options are available for MAX technology files by adding the “-bb” modifier 
(example: -tech mmi18-bb).

IMPORTING

GDSII FILES

For the purposes of this tutorial, we will be using an example GDS file 
included in the tutorial installation.

 Step 1  If MAX is still running, quit MAX (Ctrl-d).   
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If you do a “pwd” you should see the directory: 
~/mmi_private/tutorial/max.

 Step 2  Start MAX by typing “max” on the command line.

 Step 3  Select Import File... under the File menu. You should see a pop-up like 
Figure 105.

 Figure 105: Import GDSII File

 Step 4  Click on “Automatically Create MAX tech file from GDS file and then load.” 

 Click on the Expand Datatypes toggle button so that it is turned off as 
shown in the above figure.

 Click on Find... (at the lower right) and select ALU_B.gds. 

 Click on Done from the Import File pop-up. You should now see the Layer 
Names pop-up as shown in Figure 106. 
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 Figure 106: Layer Names and Type Pop-up

If the layer is not metal, via or poly, then the Layer Name is simply a 
generic name. We will change some of these names to make more 
sense. 

The Type is a category MAX uses to determine how layers are 
connected. 

TIP:
To simply have a quick look at the layout, you don’t need 
to specify any of the layer names or types.  The layers for 
poly, metal, and vias need to be defined as the correct 
type in order for Select Net to work.  In order to create fet 
and via gcells, MAX need to have the active layer 
specified as well as some of the DRC rules.  How to specify 
DRC rules is covered in the MAX User  Manual.
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 Figure 107: Changed Layer Names 

 Step 5  When prompted, click on Restart Max Automatically Now with File. 

You should now see something like Figure 108.
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 Figure 108: Results of Changing Layer Name(s) - “other” layers now 
turned OFF

 Step 6  Zoom in on the upper left corner of the layout, and type the hotkey i for 
Internals, View All to display internals for the layout. 

(Note that the “other” layers in the palette have been turned off for 
greater clarity in this tutorial.)

 Step 7  Select a net. Type the hotkey s (for Select Net, in the Select menu) to see 
layer connectivity tracing working. In Figure 109 the net attached to the 
m3 layer has been selected. 
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 Figure 109: Tracing Net Connectivity 

 To view the extent of the selected net, use the hotkey Shift-v, or click on 
Zoom to Fit Selected from the View menu. The display will zoom out 
enough to show the entirety of the selected net.

Because this layout was read in from GDSII and the technology file was 
created from this GDSII, there are no DRC rules in this particular 
technology file. Those rules can be added manually, as described in the 
MAX Technology Files chapter of the MAX User  Manual.

Mo d i f y i n g P a l e t t e / L ay e r  S t y l e s  wi t h i n  MA X

MODIFY LAYER

COLORS

Let’s change some of the layer colors and stipple patterns for the cell 
ALU_B. 

 Step 1  Zoom in on the very upper left corner of ALU_B. Click on the corner cell 
with the Button-1 or use the select cell command (hotkey: f).  You should 
now see MUX41B_0 selected as shown in Figure 110
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 Figure 110: Cell MUX41B Selected in Upper Left Corner of ALU_B 

 Step 2  Push into the cell  MUX41B using the e hotkey, as shown in Figure 111. This 
will make any changes to layer colors in the palette much easier to see.
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 Figure 111: Editing MUX41B Cell 

CHANGING

LAYER COLOR

First, we need to open the Color/Stipple Editor.

 Step 1  Click with the MIDDLE mouse button (Button-2) on m1 in the palette or, from 
the File menu, select User Prefs and then Color Editor. Figure 112 shows the 
Color/Stipple Editor and its features.
  PART 5: Importing GDSII and Customizing MAX Micro Magic, Inc. 2010 MAX  Layout Environment Ver. 5.7



IM P O RT I NG  G D S I I  A ND  C U S T O M I Z I NG  M A X

Reading in GDSII Files and MAX Technology Files
 Figure 112: Color/Stipple Editor

 Step 2  Select the layer you want to edit from the pull-down menu at the top. 

In this example we’ll be editing layer “m1”. If you brought up the 
Color/Stipple Editor using the MIDDLE mouse button on the palette, then 
m1 is already the edit layer. Otherwise, select m1 from the list.

Layer Selection pull-down menu - 
Click and hold to select layer to 
edit.

Select HSB or RGB values, or 
choose from a list of pre-set colors.

This box displays the solid fill 
color.

HSB (or RGB) slider bars. Move 
these left or right to change the 
color.

Fill pattern buttons: Solid for solid 
fill; Stipple for patterned fill; 
Outline draws an outline around 
that fill.

Stipple edit area

Pre-set Stipple patterns. Use as-is, 
or modify further as needed.

Solid fill or “nothing/empty” fill 
buttons.

Pre-set via styles.

Find... palette file button

Buttons for: Close color/stipple 
editor (without saving), Revert... (to 
last saved version), Load (palette 
file) Save (this palette as a new file)
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 Figure 113: Selecting Layer “m1” to Modify 

 Step 3  Now that you’ve chosen the layer to edit (“m1”), it’s time to choose the 
color and fill pattern. Click on the radio buttons at the top to work in either 
HSV or RGB values, and then modify the color itself using the slider bars 
underneath. 

Colors will change dynamically as you work. 

In this next illustration (Figure 114), the bright blue color has been 
changed to bright red by sliding the HSV bars. The H S and V bars 
were pushed all the way right. You can see an immediate difference 
in the layout.
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 Figure 114: Color Changed to Bright Red in Editor and Layout 

 If you prefer, select a pre-set color from the list available by clicking the 
Colors button. This list presents both color names and their RGB triplets.

CHANGING

STIPPLE

PATTERN

 Step 4  Click on the stipple toggle button. Now experiment with stipple patterns 
by clicking on the grid of squares in the stipple-pattern area to toggle the 
color on/off. 

As you make changes, these are reflected immediately in the display 
window. Figure 115 shows effects of this stipple pattern on the 
layout.

 For speedier editing, you can select the ‘solid’ square button under the 
stipple patterns and remove colors for a heavy stipple such as this 
example. And the reverse is also true — select the ‘empty’ square button 
and click on squares to set up a light stipple, or to clear a pattern and 
start fresh.
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 With the immediate feedback on the layout view, it’s very easy to see 
when a stipple pattern is “right”.

In this fashion, you can generate stipple/fill patterns to mimic those 
from any other layout editor.

 Figure 115: Large Dot Stipple Pattern in Editor and Layout 

 Step 5  Clear the edits you’ve just made by clicking on the Revert... button at the 
bottom of the color/stipple editor. Then click on Done to revert to the 
Start-up Defaults. This reverts the palette settings to the last saved version.

 If you would prefer to save the changes you’ve made to the palette, click 
on Save.   The default location for the palette override file is:
 ~/mmi_private/max/tech/ALU_B/ALU_B.override.

Since we didn’t specify a technology name we we read in the GDSII, 
the technology name defaulted to the name of the GDSII file.  When 
the technology file was created from the GDSII, MAX automatically 
made an ALU_B.palette file with the default colors.  The 
ALU_B.override is read in after the ALU_B.palette file when MAX is 
started up with this technology, and therefore overrides the layer 
color and fill patterns.
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A pop-up will open, asking if you’d like to override the default palette 
file. You can type in a new palette name in the field to create a new 
palette file, or override the current palette file.  

 Step 6  Exit MAX by either typing the hotkey Ctrl-d or selecting Exit from the File 
menu.

USING A BLACK

BACKGROUND

If you prefer working with a black background, MAX has a pre-assigned 
palette already set up.  

 Step 7  Let’s try this with our technology.  On the command line, type:

max -tech ALU_B-bb ALU_B.gds

 Step 8  View the internals (hotkey: i).

You should now see something similar to Figure 116.

 Figure 116: ALU_B Technology with Black Background

 Step 9     Exit MAX (hotkey: Ctrl-d).
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I m po r t i ng  L a y e r s  a n d  P a l e t t e  St y l e s  f r o m A n o t he r  P r o gr am

In addition to GDS and ASCII file formats, MAX can also handle industry-
standard formats, including .DRF and OpenAccess.

I m p o r t i n g  T e c h n o l o g y  I n f o r m a t i o n  F r o m  A  P D K

IMPORTING A

“DISPLAY.DRF”

FILE

The foundry generally provides you with a Physical Design Kit (PDK) 
which should contain an ASCII tech file and sometimes a separate GDS 
layer map file.  If you have layer colors and fill patterns specified for 
Cadenc’s Virtuoso layout editor, MAX can also read in that information 
from the .drf (display reference file) file.

 Step 1  From the command line (shell window) type: 

cds_convert

This opens the Technology Translation Menu, as shown in Figure 117.

 Figure 117: Technology Translation Menu for “cds_convert” to Import 
“display.drf” files

 Step 2  Click on the Find... button to select the desired ASCII Technology File. This 
file usually has an extension of .tf, .asc, or .tech. It includes the layer 
names and usually the GDSII layer number mapping information, as well 
as some basic DRC rules. 
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If the ASCII technology file does not contain the mapping information 
from GDSII layer number to layer name, then it will be in a separate 
file (usually with a .map extension). Specify it as the GDS Map File.

 The Display Reference File (.drf) is optional and is where layer colors and 
stipple patterns are defined. If not specified, cds_convert uses MAX 
default colors and stipple patterns. 

The MAX default colors use layer transparency which can make it 
easier to see multiple layers on top of each other. Each layer can 
have a transparency value from 0 to 100 (completely see-through to 
completely opaque). We suggest that you first do the conversion 
without the .drf file to see how MAX transparent layers look on your 
designs. You can always change the colors as shown in the above 
section.  If you are used to using stipple patterns for transparency, 
you may find true transparency easier on the eyes.

 Type the name of the technology in the Max technology name text area. If 
no technology name is specified, cds_convert will use the rootname of the 
ASCII technology file.

 To use this technology file, on the command line, type:

maxview -tech <tech_name>

The technology file gets put in ~/mmi_private/max/tech/<technology 
name>. To make the technology accessible to all users, put the technology 
files in $MMI_TOOLS/../mmi_local/max/tech. MAX automatically looks in 
$MMI_TOOLS/../mmi_local/max/tech  and then in 
...~/mmi_private/max/tech for technology files.

 Step 3  Since this tutorial does not contain a PDK, click on Cancel.

I m p o r t i n g  O p e n A c c e s s  D a t a b a s e  F i l e s

Micro Magic, Inc. tools support the OpenAccess database.  MAX can read 
the technology information from the OA database and create a MAX 
technology file automatically.  For information on this format, please refer 
to www.si2.org. 
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IMPORTING AN

OPENACCESS

FILE

To read in OA databases, the format of the layout files needs to be set oa.

 Step 1  From the File menu, select User Preferences, and then select General 
Setup....  The following pop-up menu will appear.

 Figure 118: General Options Pop-up Menu: Selecting OpenAccess 
Format

 Step 2  Click on the “oa” radio button to select OpenAccess format, then click 
Done.  You are now in OpenAccess mode.

 Step 3  From the File menu select Open, and you will see the following pop-up.  
From this menu, you may access your OpenAccess library and cells.
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 Figure 119: OA Cell Selection Menu for OpenAccess Format Files

 If you click on Build Max Technology, MAX will get the layer names and 
other technology information from the OA database file. Note that you 
can change these assignments afterwards as necessary.

 To have MAX automatically start up on OA mode, add the following line 
to your max.rc file:

set FILE_MODE oa

 Once you have created the technology file from the OA database, start 
up MAX with:

max -tech <tech_name>

 and MAX will launch using the correct technology and in OA mode.

C h an g i n g  H o t k e y s

With MAX, the user can change the definitions of hotkeys. Not all menu 
commands have hotkeys, so if you find that you are using a command 
often that does not have a hotkey, you might want to create one.

LISTING

HOTKEYS

BY COMMAND

 If MAX is not currently up, start it by typing “max” in a terminal window.

 Step 1  To bring up the current list of hotkeys, type SPACE or select Current Hot 
Keys... from the Help menu. You should see the form shown in Figure 120.
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 Figure 120: Current Hot Keys Pop-up Menu 

This pop-up form is useful if you want to find the hotkey assigned to 
a command. Most of the hotkeys are also found in the menus, to the 
right of the menu command. If you want to change or add a hotkey, 
you need to edit this list.

 Step 2  Click on Edit Keymap... in lower right of pop-up. You should now see a 
pop-up like Figure 121.
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By default, the hotkeys are ordered by their menu appearance. If you 
want to edit the hotkey of a specific menu command, this makes it 
easy to find. 

LISTING HOTKEYS

ALPHABETICALLY

If you want to find out which hotkeys have already been assigned, you 
want them listed in alphabetical order.

 Step 3  Click on the Alphabetical by Hotkey toggle button at the top of the pop-
up form. Notice that the Shift-k hotkey is not currently used.

 Step 4  Scroll down the list to the bottom and locate View-> Internals, Misc.-> 
Internals, View Area. Click here with the LEFT mouse button (Button-1) to 
open the menu shown in Figure 122.
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 Figure 122: Edit Key Binding Pop-up Menu

RE-MAPPING A

HOTKEY

BINDING

 Step 5  Type the letter “k” in the Hot-Key field. Click on the Shift toggle button as 
shown in Figure 123. This means that the hotkey for this command is now 
Shift-k. Click on Done.
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You should now see the Shift-k hotkey highlighted in the Edit Keymap 
pop-up. 

 If you wanted to save this information, you would click on the Save button 
so that this hotkey binding will be set the next time you start MAX. 

 You can always return to the original hotkey definitions by clicking on 
Revert to factory default keymap. If you want to test it out or just use it for 
this session of MAX, click on the Done button.

 Step 6  Click on Done. Go to the View menu and select Internals, Misc. Notice that 
Internals, View Area command now has the hotkey Shift-k listed.

You can probably see by now that after loading your GDSII files, the 
ability to customize the display and hotkeys makes using MAX pleasant 
and easy. We at Micro Magic, Inc. hope that MAX makes loading, viewing, 
editing, and creating your layout as simple, fast, and painless as possible.

I f  y o u  h a v e  p u r c h a s e d  M A X - 3 D  3 - D i m e n s i o n a l  L a y o u t  E d i t o r ,  c o n t i n u e  o n  w i t h  
t h e  s p e c i a l  t u t o r i a l  s e c t i o n  f o r  “ 3 D  D e s i g n s ” .
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